software-updates

Super-user privileges for Chromium browser

Super-user privileges for Chromium browser After apt-get install chromium and running it on Debian 12, ps alx | grep -e ^F -e ^5.*chromium returns: F UID PID PPID PRI NI VSZ RSS WCHAN STAT TTY TIME COMMAND 5 1000 3452315 3452313 20 0 33884428 16712 do_sys S ? 0:00 /usr/lib/chromium/chromium –type=zygote –crashpad-handler-pid=3452306 –enable-crash-reporter=,built on Debian …

Total answers: 1

Do .rpm files installed with rpm get update notices from dnf check-update?

Do .rpm files installed with rpm get update notices from dnf check-update? This (longer set of instructions for ex: https://code.visualstudio.com/docs/setup/linux) shows how to get the repo installed and then goes on to dnf. This direct .rpm (https://code.visualstudio.com/download) info page doesn’t say whether dnf will report updates or whether finding out about avail update notifications is …

Total answers: 1

Does 'apt update' also update nmap's scripts?

Does 'apt update' also update nmap's scripts? I’m building a Linux OVA on a VM to scan stuff with nmap. I’m using cron to keep my packages up to date: sudo apt-get update sudo apt-get upgrade sudo apt-get autoremove It’s from my understanding that nmap should be kept up-to-date with this. However, I’ve seen this …

Total answers: 1

Zorin doesn't install Dell firmware update

Zorin doesn't install Dell firmware update Regularly, I’m notified by Zorin’s Software app that a Dell firmware update is available. It’s always v1.11.0 > v1.25.0. When clicking on “Install”, I’m asked to re-boot the system. After doing so, the update notification in the Software app is gone. However, after a couple of days it always …

Total answers: 1

Updating PHP from 8.0.x to 8.0.28 using dnf

Updating PHP from 8.0.x to 8.0.28 using dnf Will this update PHP 8.0.25 to PHP 8.0.28? dnf module reset php dnf module enable php:remi-8.0 dnf update php* Asked By: anjanesh || Source Yes, updating PHP using the dnf package manager on a system running PHP 8.0.x with the following commands will update PHP to version …

Total answers: 1

Expanded Security Maintenance is not enabled on Ubuntu machine

Expanded Security Maintenance is not enabled on Ubuntu machine Upon SSH’ing into my Ubuntu MATE 22.04 machine, I am greeted with: Expanded Security Maintenance for Applications is not enabled. in Welcome to Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-60-generic x86_64) * Documentation: https://help.ubuntu.com * Management: https://landscape.canonical.com * Support: https://ubuntu.com/advantage Expanded Security Maintenance for Applications is not enabled. …

Total answers: 2

Automated patching of packages on upstream updates

Automated patching of packages on upstream updates Is there a way to automatically merge custom patches to upstream packages when they update? From what I gathered so far modifying source code requires you to maintain a separate fork of packages that you need to maintain. I’m hoping that instead some package manager or another tool …

Total answers: 1

Fedora Server 36 – update process automatically closes user’s session

Fedora Server 36 – update process automatically closes user’s session This latest Saturday and today, through VirtualBox for Fedora Server 36, as many times as I did do, was executed the sudo dnf update command, the password is written and Starts to load and show some information. It about the progress bar loading and retrieving …

Total answers: 1

What is this update exactly designed for? (new BIOS?)

What is this update exactly designed for? (new BIOS?) I own a rather older piece of server, Dell PowerEdge T20, with the latest BIOS version A20, link to Dell updates, screen of the update in case link goes dead in time: This morning, when SSH’d into this server, I was greeted with a message that …

Total answers: 1

Embedded linux remote update

Embedded linux remote update I build my own linux distribution using Yocto for Rpi CM4. I would like to have a possibility to update it remotely, without using Balena Etcher, just upload the built image and call some commands via SSH. How can I do that? I found swupdate yocto layer but I cannot confirm …

Total answers: 1

Linux Mint 21 update procedures changed

Linux Mint 21 update procedures changed Starting with Linux Mint 21 update procedures changed in a way below: Can anyone tell me how to set it up, so that it behaves normal, I mean avoid this Software application, forcing me to reboot and so on? $ sudo apt-get update; sudo apt-get dist-upgrade [sudo] password for …

Total answers: 1

Check date and time of last update to a specific apt or deb package

Check date and time of last update to a specific apt or deb package Is there a command that will return the date and time of the last update to a specific package? Currently I’m interested in the last time my xorg was updated (I know, some software will consist of more than one package) …

Total answers: 1

How to determine why the kernel updated

How to determine why the kernel updated I have an Ubuntu 20.04 VM hosted in Azure, deployed from the prevailing image at the time. It runs a couple of docker containers, and shuts down every day at 17h00, and starts up at 06h30 every morning. When I checked today, the VM was inaccessible. Eventually found …

Total answers: 2

Fedora Offline-Upgrade shutdown instead of reboot from CLI

Fedora Offline-Upgrade shutdown instead of reboot from CLI Before turning off my Laptop (which runs Fedora 36) I like to run sudo dnf offline-upgrade download -y && sudo dnf offline-upgrade reboot || sudo shutdown now So that all pending updates get installed automatically and I don’t have to worry about using the Software Center or …

Total answers: 1

How to open 'About Mozilla Firefox' (update) window with one command

How to open 'About Mozilla Firefox' (update) window with one command For some reason I have ended up using the ‘local’ (portable) version of Firefox, and it can check for updates from its dedicated window (Help – About…). Can that window be opened with one command? Asked By: cipricus || Source There is no specific …

Total answers: 1

cron-apt informed me that there are pending security updates on my Debian system but I can't find the corresponding announcement. How shall I proceed?

cron-apt informed me that there are pending security updates on my Debian system but I can't find the corresponding announcement. How shall I proceed? Today, cron-apt informed me that there are pending security updates on my Debian stable system: CRON-APT RUN [/etc/cron-apt/config]: Tue Jan 25 04:00:01 CET 2022 CRON-APT SLEEP: 3076, Tue Jan 25 04:51:17 …

Total answers: 2

How to disable a particular dbus system service under an openrc system

How to disable a particular dbus system service under an openrc system I know that one can override dbus session services in ~/.local/share/dbus-1/services But it necessarily won’t work for system services. Under openrc, I don’t get systemd’s systemctl command therefore : Is the quick and dirty (because service will be restored on next update) way …

Total answers: 2

apt complains about change of Suite from testing to stable

apt complains about change of Suite from testing to stable I’m trying to apt-get update my Debian or Devuan distribution, but am getting an error: Get:14 http://deb.devuan.org//merged beowulf InRelease [25.6 kB] E: Repository ‘http://deb.devuan.org//merged beowulf InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘stable’ N: This must be accepted explicitly before updates for this repository …

Total answers: 1

snap-store or basically any snap app cannot be run: user-dirs.dirs: Permission denied

snap-store or basically any snap app cannot be run: user-dirs.dirs: Permission denied I was running several apps that were installed with Snap Store. I was not using the system for some time and blindly run sudo apt-get update sudo apt-get upgrade sudo snap refresh after reboot bdzionk. When I start any of these apps or …

Total answers: 7

sudo pacman -Syu fails with "error: failed to commit transaction (invalid or corrupted package)"

sudo pacman -Syu fails with "error: failed to commit transaction (invalid or corrupted package)" I am trying to update an Arch Linux installation: sudo pacman -Syu It goes on for a while and then starts to write error messages such as: (691/691) checking keys in keyring [##############################################################################################] 100% (691/691) checking package integrity [##############################################################################################] 100% error: …

Total answers: 1