dist-upgrade

Debian 12 linux-image-6.1.0-18-amd64 dist-upgrade fails on nvidia GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_lock'

Debian 12 linux-image-6.1.0-18-amd64 dist-upgrade fails on nvidia GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_lock' I ran an apt-get upgrade and an apt-get dist-upgrade on a new update notified today for Debian 12. The last one is failing with this message, and can see later that it involves NVidia driver (I use the one of the …

Total answers: 3

Does Linux Mint have a direct upgrade like Ubuntu

Does Linux Mint have a direct upgrade like Ubuntu Does Linux Mint have a direct upgrade without a clean install with an USB? Asked By: john || Source Yes, the Linux Mint upgrade guide lists the available upgrade paths and provides links to the corresponding documentation. In general, you can upgrade from any given release …

Total answers: 2

What are the risks of doing apt-get upgrade(s), but never apt-get dist-upgrade(s)?

What are the risks of doing apt-get upgrade(s), but never apt-get dist-upgrade(s)? At work, I received a VM on VirtualBox. I have no clue about its composition except that it is running Debian 10. Quickly, because tools like Chrome were complaining, I had to do an apt-get update + upgrade to put packages in their …

Total answers: 3

How to do an in-place upgrade to the latest openSUSE Leap release

How to do an in-place upgrade to the latest openSUSE Leap release A major advantage of doing an in-place upgrade compared to doing a clean install, is that all accounts, configurations, and installed programs are kept intact. Using Windows Subsystem for Linux (WSL), I have installed a fresh instance of openSUSE 42. 1 How can …

Total answers: 1

unable to update/upgrade 1 package

unable to update/upgrade 1 package I am unable to update my pop-os distribution due to the inability to upgrade 1 package. apt list –upgradable -a returns Listing… Done pop-system-updater/impish 0.1.0~1657035226~21.10~6f0d903 amd64 [upgradable from: 0.1.0~1655219862~21.10~b81523a] pop-system-updater/now 0.1.0~1655219862~21.10~b81523a amd64 [installed,upgradable to: 0.1.0~1657035226~21.10~6f0d903] I tried the below functions without success sudo apt-get autoremove sudo apt-get autoclean sudo apt-get …

Total answers: 1

Error while upgrading from Fedora 35 to Fedora 36: VirtualBox requires libvpx.so.6()(64bit), but none of the providers can be installed

Error while upgrading from Fedora 35 to Fedora 36: VirtualBox requires libvpx.so.6()(64bit), but none of the providers can be installed While upgrading my system from Fedora 35 to Fedora 36, I first ran sudo dnf upgrade –refresh And then, sudo dnf system-upgrade download –releasever=36 But it is giving rise to this error: Before you continue …

Total answers: 1

On dist-upgrade: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

On dist-upgrade: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages During a dist-upgrade operation I am encountering an issue with apt packages. When running any of the following commands I encounter the same error: $ sudo apt dist-upgrade $ sudo apt –fix-broken install $ sudo apt-get autoremove Error: Reading package lists… Done …

Total answers: 1

debconf broken, can't update, install or fix any package anymore

debconf broken, can't update, install or fix any package anymore Every time I try to update or install a new package, I get these errors: ┌──(mahdi㉿kali)-[~] └─$ sudo apt update Hit:1 http://packages.microsoft.com/repos/code stable InRelease Hit:3 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic InRelease Hit:5 https://packages.sury.org/php buster InRelease Hit:6 https://repo.protonvpn.com/debian stable InRelease Hit:7 https://download.mono-project.com/repo/debian bionic InRelease Hit:8 http://ppa.launchpad.net/uget-team/ppa/ubuntu bionic InRelease Get:10 …

Total answers: 1

Full-upgrade to Debian testing fails due to libc6-dev : Breaks: libgcc-8-dev

Full-upgrade to Debian testing fails due to libc6-dev : Breaks: libgcc-8-dev I’ve just switched to bullseye (see sources below) deb http://deb.debian.org/debian/ testing main contrib non-free deb-src http://deb.debian.org/debian/ testing main contrib non-free deb http://deb.debian.org/debian/ testing-updates main contrib non-free deb-src http://deb.debian.org/debian/ testing-updates main contrib non-free deb http://deb.debian.org/debian-security testing-security main deb-src http://deb.debian.org/debian-security testing-security main deb http://security.debian.org testing-security main …

Total answers: 4

Upgrade from Fedora 30 to 31: Cannot enable multiple streams for module 'ant'

Upgrade from Fedora 30 to 31: Cannot enable multiple streams for module 'ant' I’m trying to upgrade from Fedora 30 to 31 and I’ve successfully done these two steps: dnf upgrade –refresh dnf install dnf-plugin-system-upgrade However, when I do the next: dnf system-upgrade download –releasever=31 … I get this: Before you continue ensure that your …

Total answers: 6

apt full-upgrade vs apt upgrade redundancy

apt full-upgrade vs apt upgrade redundancy This might be a possible bug, but it is something that has been bothering me for a couple of days now. The difference between apt-get upgrade and apt-get dist-upgrade has been both well-known and well-established by now i.e. upgrade installs/upgrades while dist-upgrade is capable of install/remove/upgrade if package removal …

Total answers: 1

Debian testing – upgrade "Buster" to "Bullseye" version, no server for security.debian.org

Debian testing – upgrade "Buster" to "Bullseye" version, no server for security.debian.org I tried to upgrade my Debian System using apt, the repository is set to “testing” so I expected it to change to the next version “Bullseye” from “Buster” automatically but since “Buster” moved on I get: 404 Not Found [IP: 151.101.12.204 80] when …

Total answers: 4

How do I upgrade Nixos to use a new channel nixos version?

How do I upgrade Nixos to use a new channel nixos version? I’m currently on 18.03 and would like to upgrade to 18.09. How would I go about doing this? I’ve found the following via a web search but it’s not very conclusive: https://discourse.nixos.org/t/how-to-upgrade-from-18-03-to-18-09/933 I’m assuming I could possibly just change my channel referenced by …

Total answers: 1

How to handle "obsolete" packages when upgrading distribution?

How to handle "obsolete" packages when upgrading distribution? I would like to upgrade my Debian machine from Jessie to Stretch, but aptitude is reporting that I have 19 obsolete packages. Some of these, like BerkeleyDB, I use routinely. A set of upgrade instructions say to remove any obsolete software before doing the upgrade, but I …

Total answers: 4

Why use apt-get upgrade instead of apt-get dist-upgrade?

Why use apt-get upgrade instead of apt-get dist-upgrade? I usually use apt-get update && apt-get upgrade to run my updates and upgrades instead of the GUI because it seems to run more quickly. However, I’ve noticed lately that I often get a message that one of my upgrades was held back. I then usually run …

Total answers: 4