dependencies

After Installing Python from Source, can I Uninstall the Building Dependencies?

After Installing Python from Source, can I Uninstall the Building Dependencies? I am working with very constrained embedded hardware where I cannot afford to have many packages installed; however, I need Python3.10, which I built from source (my apt only offers Python3.7). In doing so, I installed build-essential zlib1g-dev libncurses5-dev libgdbm-dev libnss3-dev libssl-dev libreadline-dev libffi-dev …

Total answers: 1

Ubuntu dependencies multi versions

Ubuntu dependencies multi versions I have a problem, i want to install multiple software, each one require specific version of dependencies. Is it possible to install multiple versions? if not, is there any approach or idea to solve the issue? Thank you Asked By: Abderahim || Source Debian-based system are designed to work with a …

Total answers: 1

Unable to install strongswan in Ubuntu 22.04

Unable to install strongswan in Ubuntu 22.04 I am trying to re-install strongswan in ubuntu 22. Ran the following commands $ sudo apt update Hit:1 https://download.docker.com/linux/ubuntu focal InRelease Hit:2 http://archive.ubuntu.com/ubuntu jammy InRelease Hit:3 http://archive.ubuntu.com/ubuntu jammy-updates InRelease Hit:4 http://archive.ubuntu.com/ubuntu jammy-backports InRelease Hit:5 http://archive.ubuntu.com/ubuntu jammy-security InRelease Reading package lists… Done Building dependency tree… Done Reading state information… …

Total answers: 1

Ubuntu + dependencies error

Ubuntu + dependencies error I have the following dependency problem. How can I solve it? Thank you The following packages have unfulfilled dependencies: zookeeper-1-2-2-0-46-server : Depends: zookeeper (= 3.8.3.1.2.2.0-46) but 3.8.4.1.2.2.0-138 is going to be installed E: Problems could not be corrected, you have retained broken packages. EDIT: Ubuntu 22.04 I’m trying to install zookeeper …

Total answers: 1

Failed to get releases for UEFI dbx: No releases found: Not compatible with org.freedesktop.fwupd version 1.7.9, requires >= 1.9.1

Failed to get releases for UEFI dbx: No releases found: Not compatible with org.freedesktop.fwupd version 1.7.9, requires >= 1.9.1 I run Linux Mint 21.3 Cinnamon 64-bit, and I get strange error which I seemingly am unable to solve: Failed to get releases for UEFI dbx: No releases found: Not compatible with org.freedesktop.fwupd version 1.7.9, requires …

Total answers: 1

What dependency solver does APT use?

What dependency solver does APT use? I noticed packages have version constraints in their metadata (e.g., git). What algorithm does APT use to satisfy these dependencies? E.g., Spack uses Clingo as its dependency solver, Conda and Mamba use libsolv, Pip uses its own custom backtracking solver. Asked By: charmoniumQ || Source APT pre-dates the idea …

Total answers: 1

Unable to remove nvidia and cuda drivers

Unable to remove nvidia and cuda drivers Question Regardless of how I got here, I really just want to completely remove nvidia and cuda drivers and reeinstall them. But, no matter what I do, I can’t get rid of them. Background I’m on Ubuntu 22.04 and I was using a working nvidia-535 driver and successfully …

Total answers: 4

Error while installing Balena Etcher

Error while installing Balena Etcher I was trying to create a bootable USB with BalenaEtcher but encountered an error when installing the program. I downloaded the main .deb file from the github release page but when I run sudo apt install ./balena-etcher_1.19.5_amd64.deb: Reading package lists… Done Building dependency tree… Done Reading state information… Done Note, …

Total answers: 1

Nvidia driver update from 525 display ports no longer working with GTX 2070

Nvidia driver update from 525 display ports no longer working with GTX 2070 Problem: After attempting to update my nvidia driver, I got stuck in a constant black screen on reboot. I was able to get back to my desktop but now my display port connections / dual monitors do not work. Only my HDMI …

Total answers: 1

Cannot upgrade Ubuntu Studio 24.04 bcs of unmet dependencies

Cannot upgrade Ubuntu Studio 24.04 bcs of unmet dependencies After an upgrade to Distributor ID: Ubuntu Description:Ubuntu Noble Numbat (development branch) Release: 24.04 Codename:noble apt won’t update bcs of unmet dependencies. The following packages have unmet dependencies: libfontconfig1 : Depends: fontconfig-config (>= 2.14.2-6ubuntu1) libfontconfig1:i386 : Depends: fontconfig-config:i386 (>= 2.14.2-6ubuntu1) E: Unmet dependencies. Try ‘apt –fix-broken …

Total answers: 1

Compiling with Libadwaita, GTK4 and C

Compiling with Libadwaita, GTK4 and C After installing the libadwaita-1-dev package on Ubuntu 23.10, I tried to compile the example from the official documentation: gcc $(pkg-config –cflags –libs gtk4) $(pkg-config –-cflags –libs libadwaita-1) hello-adwita.c -o hello Unfortunately, it didn’t work. The error message is: /usr/bin/ld: /tmp/cccNMYti.o: in function `glib_autoptr_clear_GtkApplication’: hello-adwita.c:(.text+0x1b): undefined reference to `g_object_unref’ /usr/bin/ld: …

Total answers: 2

does apt-mark hold prevent updates to package dependencies?

does apt-mark hold prevent updates to package dependencies? I have an old package on an old system, and I want to upgrade my OS. Getting the specific package to work on newer systems might be possible, but I don’t want to mess with it right now, I still want to use it. When I tried …

Total answers: 1

Installing libgkt-4-dev on Ubuntu 23.10 results in libxfixes3 version mismatch

Installing libgkt-4-dev on Ubuntu 23.10 results in libxfixes3 version mismatch I’m trying to learn gtk4 application development, but even after a bunch of various attempts to fix it, sudo apt install libgtk-4-dev still returns the following output: Reading package lists… Done Building dependency tree… Done Reading state information… Done Some packages could not be installed. …

Total answers: 1

Forticlient VPN can't be installed on 23.10

Forticlient VPN can't be installed on 23.10 To install the application, i follow the documentation available at this doc link. During the installation i found some errors: Wrong gpg key. solution Not installable libgconf-2-4. solution Not installable libappindicator1. The question is, how to solve this third error? Asked By: Pedro Yamaguchi || Source The solution …

Total answers: 2

Distinguish direct and indirect dependencies of a binary on Linux?

Distinguish direct and indirect dependencies of a binary on Linux? ldd on Linux will give the list of all shared libraries on which a given binary depends. This is usually much more extensive than the libraries that were listed on the linker command line used to create the binary: it will include most if not …

Total answers: 2

Problem with nvidia package dependencies

Problem with nvidia package dependencies I have one problem with upgrading of nvidia package. After last updating of this package I faced with such message: $ sudo apt-get upgrade Reading package lists… Done Building dependency tree… Done Reading state information… Done You might want to run ‘apt –fix-broken install’ to correct these. The following packages …

Total answers: 1

Cannot install ubuntu-desktop on Ubuntu 22.04 LTS

Cannot install ubuntu-desktop on Ubuntu 22.04 LTS I am sorry for this newbie question. I removed my desktop manager and many gnome packages by mistake in my Ubuntu 22.04 LTS. I tried sudo apt install ubuntu-desktop, which leads to: Reading package lists… Building dependency tree… Reading state information… Some packages could not be installed. This …

Total answers: 1

How to install webkitgtk-6.0 in Ubuntu 22.04

How to install webkitgtk-6.0 in Ubuntu 22.04 I am trying to install planify on Ubuntu 22.04. src/meson.build has dependency dependency(‘webkitgtk-6.0’) Could anyone please tell me, where to get this package and how I can install it? Asked By: fedor.khandarov || Source Try this: sudo apt install libwebkitgtk-6.0-4 sudo apt install libwebkitgtk-6.0-dev Answered By: R A

Total answers: 1