deb

New app center (in 23.10.1) does not load .deb packages

App center does not open .deb packages As you can see, the bug is in the title. When I open a .deb package, the App Center shows a loading icon: I have left it loading like this for more than two hours, but it continued spinning infinitely. Is this a bug in Ubuntu, or a …

Total answers: 2

Why build a .deb package vs simply including files?

Why build a .deb package vs simply including files? I’m confused as to why you would create a .deb package vs simply putting your program in a folder + additional files and writing an install script. What are the value of packages? Asked By: FourierFlux || Source The simple answer is that the primary reason …

Total answers: 1

How to install SAGA GIS 9.3.0?

How to install SAGA GIS 9.3.0? I need to install SAGA GIS for some interpolations. Sadly, sudo apt-get install saga will only install version 7.3.0, but I need version 9, preferably 9.3.0. The SourceForge repo doesn’t contain Linux binaries. The wiki page on binaries mentions a Launchpad package, but the last build is from 2017. …

Total answers: 1

Failed to fetch https://packages.openvpn.net/…/dists/lunar/InRelease 403 Forbidden

Failed to fetch https://packages.openvpn.net/…/dists/lunar/InRelease 403 Forbidden I’m running Ubuntu 23.10 on a I9 cpu + Nvidia Geforce RTX 2080 ti and the driver 545 right now. I would like to install the OpenVPN 3 client on my Ubuntu,but I’m not able to install the repository : This is the guide that I’m following : https://community.openvpn.net/openvpn/wiki/OpenVPN3Linux …

Total answers: 1

How to install Safing (Portmaster) in Ubuntu 23.10

How to install Safing (Portmaster) in Ubuntu 23.10 I fresh installed Ubuntu 23.10 after I couldn’t upgrade from 23.10. Now I want to install Safing (Portmaster) in Ubuntu 23.10, but the App Center is not able to install Safing. How can I install Safing by using or not using the App Center? I clicked the …

Total answers: 1

For Google Cloud's debian repository, which distribution corresponds to Debian Testing (currently, Trixie)?

For Google Cloud's debian repository, which distribution corresponds to Debian Testing (currently, Trixie)? On Debian Testing (currently called Trixie), I would like to install the google-cloud-cli and google-cloud-sdk-gke-gcloud-auth-plugin packages that Google Cloud offers through its debian (package archive) repository packages.cloud.google.com/apt/. But which (package archive) distribution is the correct one to use? In their official documentation, …

Total answers: 1

With what shared objects are the debug symbols in a debug deb package assocciated with?

With what shared objects are the debug symbols in a debug deb package assocciated with? I am trying to find debug symbols that are associated with various shared objects shipped under the Ubuntu 22.04 distro. For example, let’s consider the amd64 deb package: libssl3 (version 3.0.2-0ubuntu1) which ships a number of stripped shared objects. One …

Total answers: 1

When installing, command in `postinst` always results in `$?` = `0`

When installing, command in `postinst` always results in `$?` = `0` I have a postinst script in my debian package: #!/bin/bash oqm-config -g system.hostname RESULT="$?" if [ "$RESULT" -eq 1 ]; then oqm-config -s system.hostname $(hostname).local "." fi This is intended to populate a config variable (if it doesn’t exist). These commands function outside of …

Total answers: 1

why this package is not proposed to me to remove?

why this package is not proposed to me to remove? As I understand it, if a package is auto-installed and has no other packages depending on it, the system should offer to remove it. why doesn’t this happen in this case? :~$ sudo apt list –installed | grep -i zutty WARNING: apt does not have …

Total answers: 2

How do you define a dynamic default value in a Debian package template?

How do you define a dynamic default value in a Debian package template? I have a package where I want the administrator to enter a list of interface names. I’d like that list to have a default. Only each system has a different list (eth0, enp0s3, eno1, to list a few). Here is an example …

Total answers: 1

What Debian packages are there that depend on a service while building?

What Debian packages are there that depend on a service while building? I have an issue trying to build a package which depends on several other packages, some of which include a service. Said service tries to start in the postinst script and as a result fails the build because within the build environment, systemd …

Total answers: 2

Installing a new version of a software already installed?

Installing a new version of a software already installed? So I run Discord on my computer and it doesn’t come from a repository, it’s a downloaded .deb-file. Sometimes Discord wants me to update with a new .deb-file. But when I download and run that deb file "Ubuntu software" (which looks like a skinned GDebi) just …

Total answers: 2

Reinstall application above existing

Reinstall application above existing Is there a way to reinstall .deb file so that to keep all previously installed files in place ? Asked By: noname7619 || Source The simplest way would be via dpkg with a command like: sudo dpkg -i –force-overwrite {your .deb} Note: Be sure to replace {your .deb} with the proper …

Total answers: 2

Cannot stat file while copying script from deb package to /usr/local/bin in postinst

Cannot stat file while copying script from deb package to /usr/local/bin in postinst I have a script (nginx-sb-setup.sh) inside of my deb package in usr/local/bin directory. During postinst, I want to copy this usr/local/bin/nginx-sb-setup.sh which is inside of my deb package to /usr/local/bin. I have learned that dpkg -i doesn’t run in the same folder …

Total answers: 1

How do I fix missing dependencies when installing FCEUX?

How do I fix missing dependencies when installing FCEUX? I am attempting to install FCEUX from a .deb package that worked on Ubuntu 20.04 but does not install on 22.04.1 LTS. I see the following errors: Depends: libx264-155 but it is not installable Depends: libx265-179 but it is not installable E: Unable to correct problems, …

Total answers: 1

Uninstall STM32CubeIDE

Uninstall STM32CubeIDE I downloaded and installed an older version of STM32CubeIde from this site a while ago. It is a dot DEB file version 1.5. How do I completely remove this software? Ubuntu 20.04 is the OS used. Ubuntu Software doesn’t show the installed software. Actually, my Ubuntu Software doesn’t show any installed software. Thank …

Total answers: 3

snap store vs apt and debian packeges

snap store vs apt and debian packeges I was wondering if I should prefer installing apps using apt and .deb files rather than getting them through the snap. I have heard that snap is safer than apt/.deb, but it’s slower. What should I prefer? Asked By: Odysseus || Source There are no definitive rules, we …

Total answers: 1

Where is the unpacked content of a .deb file when using the "–unpack" option of dpkg?

Where is the unpacked content of a .deb file when using the "–unpack" option of dpkg? About the dpkg command, a few tutorials do mention of the –unpack option. According with jammy (1) dpkg.1 it indicates –unpack package-file… Unpack the package, but don’t configure it. If –recursive or -R option is specified, package-file must refer …

Total answers: 1

How to limit sudo for user only for rpm/deb

How to limit sudo for user only for rpm/deb Is there anyway to limit sudo for user, in order to only for invocation of rpm/deb to install packages? Asked By: Rus Zzzeta || Source Is there anyway to limit sudo for user, in order to only for invocation of rpm/deb to install packages? Yes; man …

Total answers: 2