Ubuntu DNS Error Chrome: DNS_PROBE_FINISHED_NXDOMAIN, Firefox similar

I am unable to visit most sites online in either firefox or chrome. I can access google docs so I am researching on windows 7 (dualboot) and rebooting into Ubuntu (recently upgraded to 16.04).

Test 0:

$ sudo /etc/init.d/dns-clean

(nothing happened)

Test 1:

$ dig microsoft.com
; <<>> DiG 9.10.3-P4-Ubuntu <<>> microsoft.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2944
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;microsoft.com.         IN  A

microsoft.com.      896 IN  A
microsoft.com.      896 IN  A
microsoft.com.      896 IN  A
microsoft.com.      896 IN  A
microsoft.com.      896 IN  A

;; Query time: 102 msec
;; SERVER: 2001:558:feed::1#53(2001:558:feed::1)
;; WHEN: Tue Aug 29 14:54:43 EDT 2017
;; MSG SIZE  rcvd: 122

Test 2:

$ ping reddit.com
connect: Network is unreachable

Test 3:

$ less /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Test 4:

$ less /etc/NetworkManager/NetworkManager.conf 



Test 5: Chrome

This site can’t be reached
www.reddit.com’s server DNS address could not be found.


Test 6: Firefox

Server not found
Firefox can’t find the server at www.reddit.com.
Check the address for typing errors such as ww.example.com instead of www.example.com
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Edit: Almost forgot, this seems to have started after I tried installing PlayOnLinux the other day. I uninstalled it but the problems persist.

Any thoughts?

Re: possible duplicate question : dns_probe_finished_nxdomain error caused by Ubuntu
dns_probe_finished_nxdomain error caused by Ubuntu
I clearly state in my question that the solution posed in the other thread of clearing the dns cache does not resolve my issue.

Asked By: Nick S



Step 1. Open terminal and add below command

sudo nano /etc/dhcp/dhclient.conf

Step 2. Now add below line in file

supersede domain-name-servers;

Now, save file

Step 3. Restart the network

sudo service network-manager restart


sudo systemctl restart NetworkManager.service

Refresh your page and done.

Answered By: Raja Parivesh

For me it was flushing the dns cache that way:

sudo systemd-resolve --flush-caches

You can then check the statistics in order to make sure that your cache size is now zero.

sudo systemd-resolve --statistics
Answered By: Aziz.G

For me (Ubuntu 20.04), the only working solution was to add DNS servers of Google and OpenDNS.

I did it at computer level:

sudo vim /etc/resolv.conf

And added these lines (before other nameservers):


This can be also done at router level (for all devices):

  • Go to router management -> DNS -> Set primary DNS to and secondary DNS to

See https://linuxhint.com/opendns-vs-googledns/ for more info about choosing the DNS nameservers (and checking which server is faster in your location).

Answered By: Filip Kubicz

Restarting the router solved this problem for me.

Answered By: talz

I am having the same issue.
I have tried everything from all answers and none of these work for me.
I am working right now on something which requires a lot of DNS updates and this completely blocks my work all the time. I have to go and look at the site on my phone / ipad to see if it is really working.

Is there any other possible solution ?

Answered By: Sambhav Gore

In my case I solved it from TpLink router -admin panel settings.

Go to Advance > Network > LAN settings, and change:

Primary DNS :

Secondary DNS :

Hit save then restart your router, wait to see your internet indicator lights up on your router and then reload your pages to check.

Answered By: Jood80