Fuzzy, Garbled audio with slight echo

I’ve been using Ubuntu 16.04 on a Lenovo ideapad Y410P for about a month and a half, and for the duration I’ve been having audio issues, despite to this day making sure I have installed all updates. I run a dual boot with Windows 10 and have no problems in Windows, so I’m pretty sure this is an Ubuntu or Linux issue.

Every once in a while– I see no correlation in the times it happens– my audio suddenly goes fuzzy & garbled with a slight echo. If I had to define it further I’d call it a swampy metallic sound. It is still possible to make out what sounds are playing, but they are very distorted. This problem sometimes will stop by itself– I see no correlation in the times it stops– or I can restart my computer.

The problem will exist both through the laptop speakers, and through any headphones I plug in.

The problem will exist across programs, including, but not limited to, Firefox and the ‘Test’ function in the System Settings’ Sound tab.

Most of the time my audio is fine, I can go entire days without problems. But then I can spend hours suffering distorted audio.

Asked By: JMcFar


The audio issue continues to arise on the same laptop sporadically, however I can quickly fix it by using the terminal to run alsamixer. In alsamixer, press f6, then simply click on a master volume control. The audio immediately returns to normal.

Answered By: JMcFar

I have been experiencing somewhat the same issues with my 17.10 install. There is an option in my sound menu to allow volume to go above 100%, which makes the sound garbled and incoherent, (but nowhere near as bad as you describe).

Since simply opening alsa seems to fix the problem, perhaps you should set your volume to <99%. Maybe alsa isn’t playing nice with your sound card and is pushing too much through it at times.

Answered By: J.Tho

I get symptoms similar to yours – scratchy sound. A possible fix is to restart pulseaudio. Open terminal and do the following:

$ pulseaudio --check
$ pulseaudio --k
$ pulseaudio --D
Answered By: Joshua T

It happens to me also on Ubuntu 19.04, but ONLY when using firefox. When problem arises, I shut down firefox, mute, unmute, and sound from all programs goes back to normal again.

I used Google Chrome as a browser for a month or so, and in that month, didn’t have any distortions. As soon as I went back to firefox, the problem started appearing again at least one time per day.

Answered By: lukoramu

Now I’m sure it’s this: https://bugs.launchpad.net/ubuntu/+source/speech-dispatcher/+bug/1736222

My workaround was to uninstall the speech-dispatcher package:

sudo apt remove speech-dispatcher

This also worked on Fedora (with dnf instead of apt).

Answered By: lukoramu

Ubuntu 19.10:

I had this weird sound issue too. Mainly YouTube, browser audio and other random applications would have a distorted effect when the speaker’s Balance was set to the middle.

The only thing that solved it was this answer, which shows how to reinstall pulseaudio:

sudo alsa force-reload
sudo apt remove --purge alsa-base pulseaudio
sudo apt install alsa-base pulseaudio
# Somethings might have broken so reinstall ubuntu-desktop
sudo apt install ubuntu-desktop 

Then reboot.

Answered By: Ben Winding

I discovered that FireFox was forking off some "speech-dispatcher" processes (via the Audio Mixer… dialog underneath the speaker icon on the top bar) and so I edited /etc/speech-dispatcher/speechd.conf and uncommented the line for DisableAutoSpawn

So far, so good!

Answered By: SJF

This appears to be a bug in speech-dispatcher 0.9, fixed in 0.10.0;
Ubuntu 20.04.3 still includes version 0.9.1-4

Apparently the default for AudioPulseMinLength is correct in the config file but was mistakenly set to 100 in the actual code. The solution is to edit /etc/speech-dispatcher/speechd.conf and uncomment the following line:

AudioPulseMinLength 1764

If this doesn’t fix it immediately, you may have to pkill -f speech-dispatcher and allow it to automatically restart.

Answered By: user10489

I’ve had an issue with my audio getting corrupted when using discord in the browser, and when logging out and back in.

I’ve found that a reliable solution for me, if ALSA is installed, is running the command:

$ alsactl restore

For me it clears out fuzzy/corrupted audio every time.
I’ve also had the audio get corrupted in a way that the audio is just non-existant. The same command resolved that issue as well.

(Linux Mint – Bionic)

Answered By: Ahab Devoid
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.