cannot run virtualbox on ubuntu 16.04

I tried to install virtualbox for the first time on my ubuntu 16.04 machine following the instructions here. When tried to run from terminal with command virtualbox it gave me the error below:

VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen("/usr/lib/virtualbox/",) failed: <NULL>

VirtualBox: Tip! It may help to reinstall VirtualBox.

and when tried to run by searching virtualbox an icon appeared in sidebar and after some seconds disappeared.

I tried downloading the official deb file form the virtualbox website and install with sudo apt install ./virtual... but the same error happened.

I also completely removed virtualbox with --purge option and its user and group every time I tried to reinstall.

The interesting part is that it was easy to install the Virtualbox on an ubuntu 16.04 hosted by another virtualbox on a windows machine.

Any answer or comment would be appreciated.

Edit (Solved)
Thanks to Charles the problem solved by changing the owner and group of /usr and /usr/lib to root by the following commands:

sudo chown root:root /usr
sudo chown root:root /usr/lib

My problem was that I only changed the owner by sudo chown root /usr.

Asked By: szamani20


As mentioned at VirtualBox Forums the owner and group of /usr and / or /usr/lib may have been incorrectly set.

Check the two directories with ls -ld /usr && ls -ld /usr/lib – both the user and group of the directories should be root. If not, they can be set with:

sudo chown root:root /usr /usr/lib
Answered By: Charles Green

I’d like to add that also directories permissions matter.
I’ve got the same error even with the correct owner root:root (after chown): the problem was the access level (777):

ls -ld /usr/lib
drwxrwxrwx 182 root root 20480 dic 19 15:50 /usr/lib
sudo chmod 755 /usr/lib
ls -ld /usr/lib
drwxr-xr-x 182 root root 20480 dic 19 15:50 /usr/lib

Once changed to 755 virtualbox started without problems.
Just as a reference in case anyone have the same issue.

Surely Virtualbox users could benefit of a more specific error message
(and how/when owner and permissions of the directories were changed is still something to clarify)

Answered By: Dario Corsetti
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.