gs: /MATLAB/ /bin/glnxa64/ no version information available (required by /usr/lib/

When I use in Matlab

!epstopdf "output.eps" --outfile=output.pdf

then I get one of the following message:

gs: /opt/MATLAB/R2016b/bin/glnxa64/ no version information available  (required by /usr/lib/
gs: /opt/sw/x86_64/generic/Matlab/R2016b/bin/glnxa64/ no version information available (required by /usr/lib64/
gs: /opt/sw/x86_64/generic/Matlab/R2017b/bin/glnxa64/ no version information available (required by /usr/lib64/

I am using Ghostscript 9.18 (default version of Ubuntu 16.04). (Same Problem with Ghostscript 9.07)

Asked By: JoKalliauer


no version information available means that you have an old version (of Ghostscript) see:

Therefore you have to update to Ghostscript 9.23 (or newer):

Due to the fact that Ubuntu 16.04 offers Ghostscript 9.18 and Ubuntu 18.04 offers Ghostscript 9.26 (earlier it was 9.22), you have to

Answered By: JoKalliauer

On my system (Linux Mint 21 Vanessa 64-bit), the problem lies in the incompatibility of the libraries and installed with the system and those shipped with Matlab.


  • /usr/lib/x86_64-linux-gnu/ is a symlink to /usr/lib/x86_64-linux-gnu/
  • /usr/lib/x86_64-linux-gnu/ is a symlink to /usr/lib/x86_64-linux-gnu/

shipped with the Matlab distribution:

  • R2022b/sys/os/glnxa64/ is a symlink to R2022b/sys/os/glnxa64/
  • R2022b/bin/glnxa64/ is a symlink to R2022b/bin/glnxa64/

To overcome this problem, you need to ensure that the relevant symlinks in the Matlab’s library folders point to the system library files rather than those shipped with Matlab. That is:

  • R2022b/sys/os/glnxa64/ must be a symlink to /usr/lib/x86_64-linux-gnu/
  • R2022b/bin/glnxa64/ must be a symlink to /usr/lib/x86_64-linux-gnu/

This has been an issue for many years, and the above approach always worked. For a particular version of Matlab and your system, you simply need to use the Matlab folder and system libraries that are appropriate for your system (in the above example: R2022b and whatever versions are in the /usr/lib/x86_64-linux-gnu/ folder).

Answered By: Lubos Polerecky

When I use the mex command to compile opencv c++ files or when I use mex files, i get an similar error message like this:

MATLAB/bin/glnxa64/ version `LIBTIFF_4.0′ not found (required by *)


"Invalid MEX-file ‘.mexa64’: version ‘LIBTIFF_4.0’ not found"(required by /usr/lib/x86_64-linux-gnu/

I solved it in the following way, please refer to.

sudo rm -rf /usr/local/MATLAB/R2017a/bin/glnxa64/
sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/local/MATLAB/R2017a/bin/glnxa64/

The first line of the command removes the libtiff.xo.5 file from its original path. The second command is to link /usr/lib/x86_64-linux-gnu/ to /usr/local/MATLAB/R2017a/bin/glnxa64/ This way the two file versions correspond and the problem is solved.

Execute the command locate
You will find this file in the /usr/local/MATLAB/R2017a/bin/glnxa64/ directory.

Note that the matlab version path above should be the one belonging to you.

Answered By: xing cui