Can't boot any distro without acpi=off

I have really limited Linux know-how.

Specs:

  • Asus ROG Strix G15DS-R7700X088W
  • AMD Ryzen 7 7700X
  • NVIDIA GeForce RTX 3070
  • 2x 1TB SSDs; 1x M2 NVME with W11 running, 1x SATA

Goal: Running Dual Boot with W11 on the first M2 SSD (already running fine) and Linux on the second SATA SSD

Distros I tried:

  • Nobara 39
  • Fedora 39
  • Fedora 38
  • Fedora Silverblue
  • Ubuntu 22.04
  • Pop!_OS
  • Linux Mint
  • Arch Linux
  • GarudaOS
  • GarudaOS Dr460nized

Problem I run into: I can’t boot even from the LiveUSB without the acpi=off option. If I do, I get just a black Screen (with the backlight still on) or, if I get into the Grub options first, thereā€˜s only "booting command list" visible but nothing else happens (even with "quiet" disabled, no info on the screen at all). One thing I noticed, since my keyboard, mouse and mousemat (Razerfly) have lighting, when I try to boot without the acpi=off, they go dark and stay dark. With acpi=off, the keyboard alone goes dark but then lights up again after 2-3 seconds. If I run it with acpi=off, I can boot and install, but I then have to boot every time with acpi=off. This leads to the graphics driver not being recognized by the OS and running always in 1024×768 "software rendering" resolution (even with proper drivers installed and enabled and nouveau on blacklist). As a result, having "acpi=off" enabled isn’t an option. Also, when trying to boot without acpi=off I see that straight after hitting enter, my USBs seem to go off (by seeing that the RGB on keyboard, mouse and mousepad go off completely).

I already reached out to several communities over reddit/discord/kbin/lemmy (linuxquestions, linux4noobs, asus-linux, linux, nobara, popos, and maybe even several more) but haven’t find a solution yet.

  • BIOS/UEFI is up to date, no newer version available.
  • Secure Boot is off (=set to "Custom OS")
  • Fast Boot is off

What I tried (by googling myself and/or by getting answer’s from the other comms): Boot with different options:

  • acpi=strict / acpi=force / acpi=ht / noacpi / acpi=noirq / acpi=irqfixup
  • noapic / nolapic
  • pci=nommsconf
  • pci=biosirq
  • pci=noacpi
  • iommu=soft / iommu=off
  • nomodeset / nvidia-drm.modeset=0 / nvidia-drm.modeset=1 / nouveau.blacklist=1
  • ibt=off

burn the ISOs with different software:

  • Rufus
  • Ventoy
  • Fedora Media Writer

Other:

  • swap USB Slots / Sticks
  • went through my UEFI Settings several times, trying to enable/disable tons of different options
  • disable onboard graphics with nvidia gpu enabled and the other way round (even tried by removing the nvidia card completely)
  • tried to install older versions of the distro’s with older kernels

I see with "insmode progress" in grub, that kernel and initrd are loading but after that nothing happens. No logs at all, just a black screen with backlight on or just one line stating "booting a command line" when adjusting some grub options beforehand.

I reached out to ASUS as well, but after some basic troubleshoot help (CMOS Reset, use other Distro, etc.) they let me hanging with "yeah, we don’t support it, so we can’t help".

I’m now in a state where I think about swapping my MoBo, but got the suggestion to try asking on here, so that I have all options covered. So, does someone know if/how I can tackle that?

Asked By: Varen

||

I just took a look into the manual of your computer. Those ASUS guys are really lazy. On page 12 of the manual you can read at the bottom the small note "*Note: ENERGY STAR is NOT supported on Freedos and Linux-based products.". But what does that mean? Energy Star is a technical standard which tries to achieve less power consumption of products. Modern computers do this by using ACPI. So in essence this note is indirectly telling you that this computer does not support ACPI on Linux. ACPI is an important technical component, a computer which cannot use ACPI is a crippled one, as you saw by yourself.

In my personal opinion, I regard this as a major design fault by mainboard manufacturer ASUS. They created this mainboard and saw that it was incompatible with Linux. Instead of fixing it, they made it an OEM mainboard, only sold within a complete system.

To make it more clear, it’s an hardware bug of your mainboard and the manufacturer hasn’t told you and is hoping nobody is asking.

There should be no reason why a modern Linux cannot run on a mainboard where a modern Windows can run. From technical point of view it makes no difference. But it seems the manufacturer has made a mistake and has tested this board only using Windows. The manufacturer must have made some elementary bugs in BIOS/UEFI firmware which they either cannot fix or don’t want to fix.

In my opinion this is a warranty case and I would demand at least some refund or a mainboard which works. Just stating a small note in the manual that this computer/mainboard indirectly doesn’t work with Freedos or Linux operating systems is not customer friendly and probably also against some customer protection laws.

A modern AMD64 personal computer has to be compatible with Linux when using UEFI. That’s why UEFI exists. If it’s not compatible then it’s a bug and thus it’s a warranty case. – you may tell that to the ASUS support.

Answered By: paladin
Categories: Answers Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.