modprobe fuse doesn't seem to load module

I’m trying to load the fuse kernel module but for some reason it seems like it’s not getting loaded. But I also don’t get any error message. Can someone explain to me what’s going on?

root@my-host:~# modprobe fuse
root@my-host:~# echo $?
root@my-host:~# lsmod | grep fuse 
root@my-host:~# modinfo fuse
modinfo: ERROR: Module fuse not found.
root@my-host:~# ls /lib/modules/$(uname -r)/kernel/fs/fuse/

I’m on a cloud VM:

root@my-host:~# uname -r
root@my-host:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.6 LTS
Release:    18.04
Codename:   bionic

I also rebooted the host before I ran these commands to make sure the correct kernel is running.

EDIT: In response to the comments I ran these commands:

root@my-host:~# grep fuse /lib/modules/$(uname -r)/modules.builtin
root@my-host:~# systemd-detect-virt
Asked By: MoRe


Generally, if loading a module succeeds but that module doesn’t appear in lsmod’s output, it’s because the module is built-in — i.e. it’s part of the main kernel image and is always available¹.

To check whether that’s the case, look in /lib/modules/$(uname -r)/modules.builtin:

grep fuse /lib/modules/$(uname -r)/modules.builtin

If this shows a kernel module path matching the module you expect, it means the corresponding “module” is built-in.

¹ Many built-in modules can still be disabled if necessary, see disable kernel module which is compiled in kernel (not loaded).

Answered By: Stephen Kitt
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.