Integrated Graphics Firmware Issues after system update

I would ask this on the arch-linux forums, but I can’t register (which is why I am here)

I have been using Arch for a few months now after using Manjaro for the past year or so. Two days ago, I ran sudo pacman -Syu as I routinely do, and had no issues until the next time I tried to login. I was greeted with the flashing underscore of death in the top left of the screen. I tty’d into a different console and dug around and saw that my amdgpu firmware and bluetooth firmware ran into issues on boot (attached photos of startup log) (And sorry the photos aren’t great but it’s the best I can do)

Bluetooth Error

AmdGPU error

Another issue I have is that I am unable to connect to the internet. I use wifi cause, and i tried to set it up with iwctl, but when I ran iwctl device list, no device was listed. I was able to find my wifi card using lspci -k, and the correct controller came up.

I would attach more computer information (inxi etc), but I can’t copy/paste it. Basic information is:
Asus Rog Zephyrus G14 GA401
AMD Ryzen 9 5900HS (with integrated graphics)
Nvidia RTX 3060 Mobile-Q
Using Arch Linux 11
Kernel 6.5.9

I looked around online and didn’t see anything that could help, so I chrooted into my system from a live usb, and did a complete system update, but that didn’t work. I am unsure where to go from here and any help would be greatly appreciated.

ps: if there are formatting errors, please let me know, I am still kinda new to these types of forums 😀

Asked By: Lacksal


I was able to register to the Arch Linux forum and found a solution. I needed chroot back into my system, remove some broken packages from the previous update, then reinstall them.

If anyone somehow finds themselves in this situation, here is a link to the thread post:

Answered By: Lacksal
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.