Cannot find node ' '. How to add downloaded Info document file so that info command worked?

info make opened same as man make. I’ve downloaded file from, then:

sudo cp ~/Downloads/ /usr/share/info/

sudo install-info /usr/share/info/ /usr/share/info/dir

I got info (no pun intended) from

Now there is a new entry when I do info:

  • Make: (make). Remake files automatically.

But when I select it I get Cannot find node ''. info make still displays man page, not Info document page. What could be the problem?

Asked By: Martian2020


I’ve noted other files in /usr/share/info/ are named e.g. Renaming to and rerunning below solved the problem

sudo install-info /usr/share/info/ /usr/share/info/dir

I wonder why has so named files for download. "Info document (268K bytes gzipped tar file)." Maybe on another systems files are named tar.gz? I’m on Linux Mint 21 based.

Answered By: Martian2020

The file you downloaded is an archive, you need to extract its contents:

sudo tar -C /usr/share/info -xof &&
  sudo install-info /usr/share/info/ /usr/share/info/dir

Renaming it as you did happens to work because there’s a single file in the archive, and the tar header ends up mostly ignored by info; but zless /usr/share/info/ should show you noise at the top of the page.

Answered By: Stephen Kitt
Categories: Answers Tags:
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.