Keyboard layout issue solved for linux mint

I installed a fresh Linux Mint 21.2 64bit. During the installation, the menu to choose the keyboard layout was skipped, so i couldn’t choose one.

Now after the installation, when i try to login, the keyboard layout is set to US by default. I can change it but it will reset after a reboot.

When i tried to change the keyboard layout via terminal (with may different commands), my main language i wanna set the keyboard layout to (german, de) couldn’t be found.

My System:


CPU: 6-core AMD Ryzen 5 3600 (-MT MCP-) speed/min/max: 2178/2200/3600 MHz
Kernel: 5.15.0-79-generic x86_64 Up: 38m Mem: 2422.4/31973.2 MiB (7.6%)
Storage: 6.37 TiB (12.0% used) Procs: 367 Shell: Bash inxi: 3.3.13+


Architektur:                       x86_64
  CPU Operationsmodus:             32-bit, 64-bit
  Adressgrößen:                    43 bits physical, 48 bits virtual
  Byte-Reihenfolge:                Little Endian
CPU(s):                            12
  Liste der Online-CPU(s):         0-11
Anbieterkennung:                   AuthenticAMD
  Modellname:                      AMD Ryzen 5 3600 6-Core Processor
    Prozessorfamilie:              23
    Modell:                        113
    Thread(s) pro Kern:            2
    Kern(e) pro Socket:            6
    Sockel:                        1
    Stepping:                      0
    Frequenzanhebung:              aktiviert
    Maximale Taktfrequenz der CPU: 3600,0000
    Minimale Taktfrequenz der CPU: 2200,0000
    BogoMIPS:                      7186.66


OS: Linux Mint 21.2 x86_64
Shell: bash 5.1.16 
Resolution: 1920x1080, 1920x1080 
DE: Cinnamon 
WM: Mutter (Muffin) 
CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz 
GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590 
Memory: 2019MiB / 31973MiB 

dmidecode -t bios:

# dmidecode 3.3
Getting SMBIOS data from sysfs.
SMBIOS 3.3.0 present.

Handle 0x0000, DMI type 0, 26 bytes
BIOS Information
    Vendor: American Megatrends Inc.
    Version: 1202
    Release Date: 10/21/2020
    Address: 0xF0000
    Runtime Size: 64 kB
    ROM Size: 16 MB
        PCI is supported
        APM is supported
        BIOS is upgradeable
        BIOS shadowing is allowed
        Boot from CD is supported
        Selectable boot is supported
        BIOS ROM is socketed
        EDD is supported
        5.25"/1.2 MB floppy services are supported (int 13h)
        3.5"/720 kB floppy services are supported (int 13h)
        3.5"/2.88 MB floppy services are supported (int 13h)
        Print screen service is supported (int 5h)
        8042 keyboard services are supported (int 9h)
        Serial services are supported (int 14h)
        Printer services are supported (int 17h)
        ACPI is supported
        USB legacy is supported
        BIOS boot specification is supported
        Targeted content distribution is supported
        UEFI is supported
    BIOS Revision: 5.17

Handle 0x0044, DMI type 13, 22 bytes
BIOS Language Information
    Language Description Format: Long
    Installable Languages: 9
    Currently Installed Language: de|DE|iso8859-1

dmidecode -t system:

# dmidecode 3.3
Getting SMBIOS data from sysfs.
SMBIOS 3.3.0 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
    Manufacturer: ASUS
    Product Name: System Product Name
    Version: System Version
    Serial Number: System Serial Number
    UUID: 3465b530-6419-cc77-4ad6-f02f741cc591
    Wake-up Type: Power Switch
    SKU Number: SKU
    Family: To be filled by O.E.M.
Asked By: DasMoorhuhn


What caused the issue?

This issue was caused by my keyboard. I have the corsair K57 Wireless RGB. When i start the installer with the keyboard connected via the USB dongle, the menu to choose the keyboard layout was skipped and i couldn’t go back to it. When i press the back button, i’ll see the menu to choose the display language.

What solved that?

When i stared the installer with my keyboard connected via USB cable, i can choose the keyboard layout without any problems.

What solved that issue for a installed Mint?

I edited the /etc/default/keyboard file.

Old config:


# Consult the keyboard(5) manual page.



New config:


# Consult the keyboard(5) manual page.



After a reboot, it is set to german.

I’m not sure why the USB dongle caused that issue but i found a solution, that works for me. I hope, that this could help anyone in any way.

Answered By: DasMoorhuhn
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.