my usb hard drive is only showing up in lsusb

I have a 500GB WD My Passport Hard Drive And it doesn’t show up on my computer, Which is running arch linux. i’ve tried searching for solutions, however most of them are only if the drive dosen’t show up in lsusb. My drive shows up in lsusb but nowhere else. here is the output of some commands:


Bus 002 Device 011: ID 1058:0730 Western Digital Technologies, Inc. My Passport Essential (WDBACY) #My Drive
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
Bus 001 Device 002: ID 0408:2010 Quanta Computer, Inc. Chromebook HD Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ls /dev:

acpi_thermal_rel  disk/        gpiochip2     mem           net/    rtc0      tty11  tty22  tty33  tty44  tty55  tty9    ttyS19  ttyS3    urandom      vcsa1  vcsu6
autofs            dma_heap/    gpiochip3     mmcblk1       null    shm/      tty12  tty23  tty34  tty45  tty56  ttyS0   ttyS2   ttyS30   userfaultfd  vcsa2  vfio/
block/            dri/         hpet          mmcblk1boot0  nvram   snapshot  tty13  tty24  tty35  tty46  tty57  ttyS1   ttyS20  ttyS31   userio       vcsa3  vga_arbiter
btrfs-control     drm_dp_aux0  hugepages/    mmcblk1boot1  port    snd/      tty14  tty25  tty36  tty47  tty58  ttyS10  ttyS21  ttyS4    v4l/         vcsa4  vhci
bus/              drm_dp_aux1  hwrng         mmcblk1p1     ppp     stderr@   tty15  tty26  tty37  tty48  tty59  ttyS11  ttyS22  ttyS5    vcs          vcsa5  vhost-net
char/             drm_dp_aux2  input/        mmcblk1p2     psaux   stdin@    tty16  tty27  tty38  tty49  tty6   ttyS12  ttyS23  ttyS6    vcs1         vcsa6  vhost-vsock
console           fb0          kmsg          mmcblk1rpmb   ptmx    stdout@   tty17  tty28  tty39  tty5   tty60  ttyS13  ttyS24  ttyS7    vcs2         vcsu   video0
core@             fd@          kvm           mqueue/       ptp0    tpm0      tty18  tty29  tty4   tty50  tty61  ttyS14  ttyS25  ttyS8    vcs3         vcsu1  video1
cpu/              full         log@          mtd0          pts/    tty       tty19  tty3   tty40  tty51  tty62  ttyS15  ttyS26  ttyS9    vcs4         vcsu2  watchdog
cpu_dma_latency   fuse         loop-control  mtd0ro        random  tty0      tty2   tty30  tty41  tty52  tty63  ttyS16  ttyS27  udmabuf  vcs5         vcsu3  watchdog0
cros_ec           gpiochip0    mapper/       mtd1          rfkill  tty1      tty20  tty31  tty42  tty53  tty7   ttyS17  ttyS28  uhid     vcs6         vcsu4  zero
cuse              gpiochip1    media0        mtd1ro        rtc@    tty10     tty21  tty32  tty43  tty54  tty8   ttyS18  ttyS29  uinput   vcsa         vcsu5  zram0

I’ve tried different ports and cables but nothing works

Edit 1

Output of lsusb -t and dmesg as requested by @JaromandaX

lsusb -t:

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
    |__ Port 2: Dev 12, If 0, Class=Mass Storage, Driver=, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/7p, 480M
    |__ Port 4: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 4: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 5: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 5: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M


[14304.208994] usb 2-2: LPM exit latency is zeroed, disabling LPM.
[14304.209819] usb 2-2: New USB device found, idVendor=1058, idProduct=0730, bcdDevice=10.12
[14304.209853] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[14304.209870] usb 2-2: Product: My Passport 0730
[14304.209885] usb 2-2: Manufacturer: Western Digital
[14304.209897] usb 2-2: SerialNumber: 57584A314142303832313830
Asked By: xorger


I’ve managed to solve the issue by simply installing mkinitcpio-firmware from the AUR. My install was missing firmware/drivers for xhci_pci (i noticed it in an upgrade), which as pointed out by @JaromandaX was also listed as missing in the output of lsusb -t.

Answered By: xorger