I am unable to run `apt update` or `apt upgrade` on Maru, why?

I am using Maru v0.6.8 for Nexus 5 (hammerhead).

When I try to run apt update or apt upgrade, I am unable to establish a connection to the servers, so I cannot perform the update.

What am I doing wrong? Is it still possible to perform an update on Maru?

Asked By: Chris.M.

||

You need to modify your /etc/apt/sources.list file.

The servers for stretch, for your maru-os version, are now accessible at:

http://archive.debian.org/

Edit the file:

nano /etc/apt/sources.list

Add the following lines and comment out or delete the old lines.

deb http://archive.debian.org/debian/ stretch main contrib
deb http://archive.debian.org/debian-security stretch/updates main

After that, you can run apt update && apt upgrade.

Answered By: Blockchain Office
Categories: Answers Tags:
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.