No video playback or no sound after launching a game (Minecraft)


I played a little around with Minecraft mods and wanted to do some modding myself. And since Linux runs Minecraft a lot faster on my machine (with the proprietary nVidia driver), why not program on Linux. Also i like the developer tools on Linux much better.

So i installed the driver on my Machine:

  • Ryzen 3800X
  • GTX 1060 3GB OC (Driver: 515.48.07)


  • Arch Linux (Kernel 5.18.6)
  • gnome-shell (42.2-1)
  • Minecraft Launcher (1.0.1221)
  • Pulseaudio (16.1.1)


I watch some videos on the topic of modding and after Minecraft launches and gets to the title screen, a few things start to break.

What I discovered:

  • Firefox/Librewolf refuses to playback youtube videos
    • it starts a few milliseconds of the videos and then stops
    • it’s not a network problem
    • it buffers the video like it normally would
  • VLC media player behaves weirdly
    • no sound
    • the actual video is played in a second window, the main VLC window is empty but contains the playback bar
  • Spotify cannot playback music
    • one time it playes music but there is no sound output (in general)
    • sometimes it errors: Something went wrong

There are a view differences with each try:

  • a few times it kept the audio output to line-out, as I configured it, but still didn’t output any audio
  • most recently starting Minecraft changed the audio output to my HDMI monitor
    • setting the output back to line-out manually kept me from hearing anything
    • I was able to hear Minecraft audio after that

What I tried

A logout/login resets everything: Sound works until I run Minecraft. I suspect the pulseaudio-daemon gets restarted.
I have no idea how to start, what logs to view or if I need to install any additional software for audio to work.

In addition, I launched the above programs from a terminal, there was no unusual output or error messages.

Asked By: Zacki


You could try using PipeWire instead of PulseAudio and see if it resolves the audio issue.

sudo pacman -S pipewire pipewire-pulse wireplumber xdg-desktop-portal-gnome

systemctl –user enable wireplumber.service pipewire.service pipewire-pulse.service

It should automatically remove and replace PulseAudio.
If it does not remove it because of dependencies then first run: sudo pacman -Rdd PulseAudio

Answered By: Regis
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.