v4l2loopback /dev/video2 Not being created

Running: Arch Linux, using package "v4l2loopback-dkms"

Software I’m trying to get running:

This software uses v4l2loopback, which I’ve setup a few times successfully.

I have two files to load v4l2loopback on boot, with these contents:

The first file simply loads the module on boot.


Contents: v4l2loopback

This second file creates a dummy output device at /dev/video2


Contents: options v4l2loopback devices=1 exclusive_caps=1 video_nr=2 card_label="fake-cam"

However, I do not have a /dev/video2 which these files should create. The "video_nr=2" is what should make it map directly to /dev/video2

The module is loaded, trying to unload it results in this error:

$ sudo modprobe -r v4l2loopback
modprobe: FATAL: Module v4l2loopback is in use.

However, if I try to manually create a video output, it just simply hangs for hours with seemingly no progress or errors:

$ sudo modprobe v4l2loopback devices=1 exclusive_caps=1 video_nr=2 card_label="fake-cam"
Nothing happens, and I've let it sit there for over 60 minutes

I’ve been reading the README, they state that /sys/devices/virtual/video4linux should contain a list of the devices, but I don’t even have the video4linux folder. I’ve tried reinstalling the v4l2loopback package to no avail.

I also already have my linux-headers installed.

I have tried rebooting.

Asked By: Matt.Brantley


After installing a kernel update to 5.18.2, everything was suddenly working. I’m assuming it was something with that version.

Answered By: Matt.Brantley
Categories: Answers Tags:
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.