ImportError /usr/lib64/libQt5Core.so.5 – in several software packages

Working with Fedora 35: I want to run a few different software packages that share a dependency, seemingly Qt.

In the shell, I get this response, from Cadence and other software:

      ImportError: /lib64/libQt5Core.so.5: version `Qt_5_PRIVATE_API' not found (required by /usr/local/lib/python3.10/site-packages/PyQt5-5.15.6-py3.10-linux-x86_64.egg/PyQt5/QtCore.abi3.so)

ldconfig -p | grep "libQt5Core.so.5" gets me

    libQt5Core.so.5 (libc6,x86-64, OS ABI: Linux 3.17.0) => /lib64/libQt5Core.so.5

If I remove /lib64/libQt5Core.so.5 I get

     ImportError: libQt5Core.so.5: cannot open shared object file: No such file or directory

Reinstalling python3-pyqt5-sip or other qt, lib or python dependencies does not seem to help.

So, libQt5Core.so.5 is found by the system, but it does not work. Though others with Fedora 35 do not have this problem. How can I provide Pathon with the required Qt_5_PRIVATE_API?

Asked By: ingli

||

Thanks to the comment by @MarkusM├╝ller, I traced back the issue to another package that had installed PyQt at an unexpected place.

The solution was to remove the other package and its dependencies. Then reinstalling Cadence worked and it ran.

Answered By: ingli

try to install qt5-default (that’s the debian package name)

Answered By: Pat cm pro

I also got this error when use julialang in jupyter notebook at my Fedora 36, because I use anaconda, the problem solved by replace libQt5Core.so.5 at directory anaconda3/lib with file libQt5Core.so.5 /usr/lib64

Answered By: Reza Ervani
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.