How do I fix fonts not rendering and missing letters?

I have a fresh installation of Ubuntu 14.10 on my laptop. It appears that letters are missing from files and folders, as well as menus and configuration windows. I’m not sure where to start in order to fix this.

enter image description here
enter image description here

Asked By: Gunther

||

I had the same problem, and found a post that suggested changing the font size of the “ubuntu” default font (had to install something called ubuntu tweaks to be able to do so). After changing the font size, everything was displayed correctly.

I still have some issues with my terminal blanking out once in a while, but just pressing enter a few times, and everything reappears. Most likely some sort of graphic driver bug, but at least the font size change fixed most of the problem for me

Answered By: user385979

It might be an driver issue. If you’re using an Intel graphics, try installing the latest(1.0.8) Intel Graphics Installer for Linux, which supports 14.10. I had same problem with my 5th generation i5 laptop but it solved this problem.

Answered By: Mics

It looks like the issue was fixed in Ubuntu 15.04. I’ve upgraded and the problem is no longer an issue.

During the upgrade I did notice that several AMD specific packages were installed.

Answered By: Gunther

I had the same problem on my new Dell laptop with IntelĀ® HD Graphics 5500 (Broadwell GT2). If you had dependence problem when installing the above Graphic Installer for Linux, you can install GDebi Package Installer which can easily solve dependence issues.

Or first install GDebi

sudo apt-get install gdebi

Download the 64 bit driver for an X64 system or the 32 bit version for an X86.

wget https://download.01.org/gfx/ubuntu/14.10/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb

Finally, use GDebi to install that driver

sudo gdebi intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb 
Answered By: user304461

Sometimes I have this issue using Ubuntu 15.04 too. A quick and dirty workaround consists of restarting X (sudo service lightdm restart)

Be aware that this kills all your open applications and you will lose any data that has not been saved.

Answered By: mdesantis

I had the same problem on my Dell Inspiron with 5th generation i5 running Ubuntu 14.04. Luckily I found an easy solution for this. First – install Ubuntu Tweak (following commands work for installing it):

sudo add-apt-repository ppa:tualatrix/ppa 
sudo apt-get update
sudo apt-get install ubuntu-tweak

Then, go to Fonts, change Antialiasing option from
Subpixels Antialiasing (LCD screens only) to Standard Grayscale Aliasing and everything seems to work fine. In fact, the problem immediately appears/disappears on changing the setting, so seems this is indeed the possible cause.

Graphical Guide — Ubuntu Tweak tool

With missing letters, you might have trouble finding the “Antialiasing” label etc. Here’s a graphical guide on how the tool looks with working fonts, to help you find where to click.

In the first window, you must pick the “Tweaks” tab in the top row (third from the left — i.e. the central one), then “Fonts” (first icon on the left in the first row):

Ubuntu Tweak -> Tweaks -> Fonts

Then, click the bottom choice bar, and choose the middle option (I can’t show a screenshot with the choice bar opened, unfortunately, as Ubuntu doesn’t seem to react to me pressing the PrtScr key then :-/)

Antialiasing choice bar

Graphical Guide — Unity Tweak tool

Similar guide as above, but for the Unity Tweak tool.

After starting the tool, click “Fonts” (right-most icon in the third row):

Unity Tweak -> Fonts

Then click the marked choice bar, and select the middle option when it opens:

Fonts -> Appearance -> Antialiasing

Answered By: workwise

For me this usually happens (sooner) when I got a second display hooked up to the laptop.
Changing the aliasing using ubuntu tweak only temporarily solves the problem.
Same for changing the font size using ubuntu’s displays.

Installing the Intel Graphics Installer for Linux (which is at version 1.1.0 now) doesn’t seem to do anything at all. I ran the installer through the software center without any problems.

I have been using this workaround for a day now without any problems. On ubuntu 14.04:

Create or edit /etc/X11/xorg.conf
Add the code below, save and reboot

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
EndSection
Answered By: firfin

With XFCE I had the same issue. Fixed after disabled DPI font resolution:

enter image description here

Answered By: Rfraile
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.