Intel Dual Band Wireless 7265 dropping connection

I am running Ubuntu 14.04.01 LTS on an Acer V Nitro laptop which has an Intel Dual Band Wireless 7265 controller. The driver version is 3.13.0-45-generic with firmware 22.24.8.0. The connection is stable for 30-40 minutes and after, it disconnects. Are necessary several reconnect attempts, sometime a restart in order to reconnect to the WiFi network.

Did anyone face this issue with this controller? What do you recommend to diagnose the issue?

Asked By: garzanti

||

A lot of Intel wifi cards exhibit this issue until you echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf and reboot

Answered By: Jeremy31

The root cause is described in this blog post It seems that there are some bugs in the Intel iwlwifi driver for 802.11N protocol for the kernel/firmware versions 3.13.0-45-generic/22.24.8.0. The temporary solution it is to disable 802.11N which is an work-around until the issue will be fixed. That means that I will not use the full capacity of the 7265 controller, which will be limited to 54MBs.

sudo sh -c 'echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf'
Answered By: garzanti

I have a non-software solution for that. Warming up the machine.
Yes you’re seeing it right. In the beginning my laptop (ASUS UX305FA) could not connect to some specific WIFI device. one day I just put it in the soft-case and brought it around, the machine was a little bit warmer than before. Suddenly it connected to the WIFI network which was not able to link.
This is more like a magic trick but it works for me… and I am using that WIFI spot now.

Answered By: MTP1984

Wheeee! After a couple hours putzing around on the Internet, I found a solution that works for 7260/7265 with even newer firmware for 7265D devices.

Per the official driver page: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

7260 and 7265 will not be supported by the newest firmware versions:
the last firmware that was released for these devices is -17.ucode.
Bug fixes will be ported to -17.ucode. Note that 7265D can run later
firmware versions. In order to determine if your 7265 device is a ‘D’
version, you can check the dmesg output:

Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210 The revision
number of a 7265D device is 0x210, if you see any other number, you
have a 7265 device.

So, I ran dmesg | grep Wireless and saw I did have device code 0x210.

As such, I was able to use https://github.com/OpenELEC/iwlwifi-firmware/blob/master/firmware/iwlwifi-7265D-21.ucode

Edit: This file is now gone. MAYBE https://github.com/OpenELEC/iwlwifi-firmware/blob/master/firmware/iwlwifi-7265D-22.ucode may work, but I have not tested this.

**If you do not have a 7265D per the dmesg command above, instead use: ** https://github.com/OpenELEC/iwlwifi-firmware/blob/master/firmware/iwlwifi-7265D-17.ucode

Edit: This file is also missing. Either find a new driver that works, or search for old files in git history: https://github.com/OpenELEC/iwlwifi-firmware/commits/master/firmware

Next, I had a look in /lib/firmware, and noticed that I only had the -16.ucode file. So, I went to the git repo, downloaded the file from git, then used:
sudo cp ~/Downloads/iwlwifi-726* /lib/firmware
restarted my wifi, and actually got a usable connection!

Note that I tried both 11n_disable=8 and 11n_disable=1 (tried each one separately) to no avail. With this updated firmware, I was able to remove these workarounds.

Answered By: Ajax