wireshark: Couldn't run /usr/sbin/dumpcap in child process

Possible Duplicate:
How to add write permissions for a group?

When I run Wireshark, It shows the following message:

Couldn't run /usr/sbin/dumpcap in child process: Permission denied
Are you a member of the 'wireshark' group? Try running
'usermod -a -G wireshark _your_username_' as root.

I ran this command: usermod -a -G wireshark myusername and checked my groups using groups myusername and I was added to the wireshark group. But I still get that error message.

[nima@nma ~]$ groups nima
nima : nima wheel dialout wireshark
[nima@nma ~]$ ls -l /usr/sbin/dumpcap 
-rwxr-x--- 1 root wireshark 67884 Aug 16 12:04 /usr/sbin/dumpcap
[nima@nma ~]$ /usr/sbin/dumpcap
-bash: /usr/sbin/dumpcap: Permission denied

What’s the problem?

Asked By: Omid

||

Did you logout and then login and try the command?

Answered By: mdpc

You need to update your group IDs by using newgrp.

Answered By: Chris Down
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.