what is a .fuse_hidden file and why do they exist?

I have a folder where I transfer home videos from a camcorder to. I find two files in this folder that are not videos…

  1. .fuse_hidden0000002c00000001
  2. .fuse_hidden0000002600000002

What are these files, and can they be safely deleted?

Asked By: barrypicker

||

You can safely ignore .fuse_hiddenXXXX files. It means a file was
deleted but there is at least one software which is still using it, so
it can’t be removed permanently.

It will be done automatically when the relevant software stops using
the file or exists. Such files are always gone after umount/reboot.
This is how Linux and any Unix works but only FUSE exposes these files
to the user.

These are likely files that were meant to be deleted but are somehow still in use.UBF

Answered By: Mitch

for me, it was Sonarr that was creating these keepalive files.
I have Sonarr running in a docker, with access to the tv-shows on another server.
On this server, the files are being created.
Stopping the docker container allowed me to remove the files permanently.

Answered By: Tim Chaubet

I had such a file, and I was unable to delete the folder it was located in.

Turns out it was a vim swap file. Closing the vim session(in another terminal) solved the issue.

Answered By: Yashasvi.G

I had 10GB of fuse files in my Downloads that had a last-modified date of a year and a half ago, so I just deleted them. I ran the lsof command above and it didn’t show anything using the file (which would have been really surprising)

I’ll uhhh… update this answer I guess if I notice anything went badly from that.

Answered By: MalcolmOcean

Find out which process is using the hidden .fuseXXX file(s) and stop the process. Then you can remove the file(s).

$ lsof {{dir-name}}/.fuse_hidde... 
COMMAND | PID | USER | FD | TYPE | DEVICE | SIZE/OFF | NODE | NAME
  ....  |<PID>| .... | .. | .... | ...... | ........ | .fuse_hidden 

$ sudo kill <PID>
Answered By: bereket gebredingle

These files can be created on Linux based systems including Chromebook after deleting files and the program used before deletion has not released them or a system shut down suddenly for whatever reason before the delete process completed, which can happen in some instances, and in the case of many of them existing in the same folder there is usually a program fault where the program does not release them after finishing with them, as some may know you can do some file manipulation tasks on files such as delete and move while a program is using files, unlike windows Linux can manage this and completes the tasks after the program using them releases them. they are then deleted or moved etc, if you are curious as to what they were and know what file types you stored in the folder, rename them and the extension then open them, if you have the correct extension they will open in the default program.

Answered By: John Moore
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.