Virtualbox does not run: NS_ERROR_FAILURE

here is ubuntu 12.10

virtual-box is somehow not working:

I was trying to install win7 on to an usb-hard-disk.

boinc is switched off and RAM-size is set to 4096 MB (too big ? of possible 8 Gibi )

report of virtual-box is:

the com-object for virtualbox could not be created.

the application is now ended.

Start tag expected, '<' not found.

Location: '/home/$user/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.

/build/buildd/virtualbox-4.1.18-dfsg/src/VBox/Main/src-server/VirtualBoxImpl.cpp[484] (nsresult VirtualBox::init()).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:VirtualBox
Interface:IVirtualBox {c28be65f-1a8f-43b4-81f1-eb60cb516e66}

comment of me:
why is virtualbox installing xml into folder of $user in .VirtualBox ?
should it not be on usb-harddisk ? (with 500 Gibi )

first installation attempt was breaking off (with win7 in 64Bit)
should I try virtual-box (ubuntu 64Bit) with win7 in 32Bit ?
should I leave RAM-size of virtual-box to default 512 MB ?

thanks for reply

Asked By: dschinn1001

||

There seems to be nothing wrong with your Virtual Box settings. However the error you see may be related to a previous fail to install Windows leaving unwanted reference to this installation in your Virtual Box settings (that are usually and correctly located in your $HOME).

The issue also may also have come from an installation to a removable drive. Installing the virtual disk .vdi file to an external USB drive is possible but it may lead to unwanted side effects from changed media location or mount points. In addition we then need to make sure the virtualbox user has read and write access to this external drive. Also we obviously should then not access this USB drive from the virtual OS.

To solve the issue you may find a solution in the following question where people recommend reinstalling Virtual Box:

Answered By: Takkat

The file /home/$user/.VirtualBox/VirtualBox.xml is not valid. It’s not valid XML. More then likely you edited the file by hand or some other tool did.

Your ram sizes and everything else seem fine.

Can you pastie the config file, maybe it’s something easy we can fix.

Answered By: coteyr

The most simple decision, that i found:

  1. enter into the folder /home/$user/.VirtualBox/
  2. find there file VirtualBox.xml-prev, this is backed up the configurations of Virtual Box
  3. delete VirtualBox.xml
  4. and change name VirtualBox.xml-prev to VirtualBox.xml.
Answered By: Vladimir

Run the following commands in terminal:

ls -la .VirtualBox/VirtualBox.xml*
cp .VirtualBox/VirtualBox.xml-prev .VirtualBox/VirtualBox.xml
Answered By: NAmiq

Probably due to some updates. It happened to me. A simple command can fix the problem:

sudo /etc/init.d/vboxdrv setup
Answered By: hdoghmen

I had installed VirtualBox from universal repository, and I solved with this command:

sudo dpkg-reconfigure virtualbox-dkms
Answered By: Stefano

If you’re using Oracle Virtualbox you can try recompiling everything by running /sbin/vboxconfig as root which executes vboxdrv.sh.
This works with Ubuntu 16.04 and Virtualbox 5.1

Answered By: Lee

I had such an error because ~/.config/VirtualBox/VirtualBox.xml was empty. Just deleting it made it work for me.

Answered By: nafg

I got this problem and my VirtualBox was installed from VirtualBox.org. I installed(didn’t bother to uninstall) VirtualBox again using

sudo apt-get install virtualbox

And this started working fine, yeah!!!

Answered By: Binod Kalathil

My perspective in general for all errors, missing files/packages,etc; is:

  1. Restart into the most updated generic linux headers (recovery mode)

  2. Do the following in order:

    check file system checker
    repair broken packages
    clean system
    
  3. Resume boot

  4. restart again as in the standard grub boot loader

  5. Start virtual box again and solved.

I feel this goes for most problems and bypasses researching and entering codes when it does everything for you (finding missing files and repairs them, repairs pakcges, and cleans out the unneccesary)

Answered By: Wes

This issue happened to me after the process of setting up a virtual machine failed.

It was resolved after deleting (or renaming) the /home/{user}/.config/Virtualbox folder

Answered By: matyas

Solutions varies from people.
Some problems of hardware occured that the disk where I installed my virtual machines became read-only
I booted that disk (windows 10) and reboot back, trying to remove the problems.
It worked.
I found that when I attempted to apply changes of my virtual machine.

Answered By: chi chow

Had this same problem on a Mac OS I removed the VirtualBox.xml and it then

rm VirtualBox.xml
Answered By: williamvivas
dpkg-reconfigure virtualbox-dkms
service virtualbox restart
Answered By: BeatingBytes

I had the same issue in a dual boot environment. Disk was used in Windows 10, shut down (without shift), the disk is locked in Ubuntu, started Ubuntu, attempted to start the VM and error came up. To fix I had to boot back in Windows 10, shut down properly (with shift pressed) then came back to Ubuntu and started VM without issues.

Answered By: Marius

Hopefully this helps someone. I had the same error message. In my case, I was dual booting Linux and Windows. The .vdi file was on another partition. Even shutting down Windows properly did not solve it. On Linux I used this command:

sudo ntfsfix /dev/sda1

After that I was able to boot the VM as usual.

Answered By: kurdtpage

This happened to me when the user (defined by VBOXWEB_USER in /etc/init.d/virtualbox) had no home directory. Re-creating the user, with a home directory, resolved the issue.

Answered By: schmeel

For me installing from .run file instead of .deb archive worked fine. You can find it under "All distributions" link on virtualbox downloads page (https://www.virtualbox.org/wiki/Linux_Downloads)

Answered By: George Vinokhodov

The solution for me (VirtualBox 6.1) was to install the last version of the Extension Pack @ https://www.virtualbox.org/wiki/Downloads

Answered By: cnxsoft

For me it has been an issue with the enabled USB 3.0 Controller Mode. When I disabled the USB controller I have been able to start the VM and this strange NS_ERROR_FAILURE disappeared.

After that I simple re-install / update the "Extension Pack" in order to enable again the USB 3.0 support. See also How to set up USB for Virtualbox? in case you are not familiar with that.

May be it helps

Answered By: megloff

sudo /etc/init.d/virtualbox setup

For me this fixed the issue. I am running virtual box 6.0 on ubuntu 22.04

Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.