Why do I get 'error while loading shared libraries: libssl.so.6 cannot open shared object file' even after I run ldconfig?

The symlink libssl.so.6 shows up in /usr/lib/x86_64-linux-gnu, and I ran ldconfig but I still get this error:

error while loading shared libraries: libssl.so.6: cannot open shared object file: No such file or directory

Is it a permissions issue or the link is not properly defined?

Update after running ldd on the binary:

    linux-vdso.so.1 =>  (0x00007fff1efe2000)
    libssl.so.6 => not found
    libcrypto.so.6 => not found
    libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007feb2a3c4000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007feb2a1bb000)
    libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007feb29f82000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007feb29d65000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007feb29b60000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007feb297a1000)
    /lib64/ld-linux-x86-64.so.2 (0x00007feb2b159000)
Asked By: blueseal

||

From the ldd command it looks like the binary is looking in /lib/x86_64-linux-gnu and not /usr/lib/x86_64-linux-gnu where you found the symlink.

Try running these and see if you still get the same error:

sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /lib/x86_64-linux-gnu/libcrypto.so.6
sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 /lib/x86_64-linux-gnu/libssl.so.6
Answered By: devnull
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.