Detect init system using the shell

This may have more to do with detecting operating systems, but I specifically need the init system currently in use on the system.

Fedora 15 and Ubuntu now use systemd, Ubuntu used to use Upstart (long time default until 15.04), while others use variations of System V.

I have an application that I am writing to be a cross-platform daemon. The init scripts are being dynamically generated based on parameters that can be passed in on configure.

What I’d like to do is only generate the script for the particular init system that they are using. This way the install script can be run reasonably without parameters as root and the daemon can be “installed” automagically.

This is what I’ve come up with:

  • Search for systemd, upstart, etc in /bin
  • Compare /proc/1/comm to the systemd, upstart, etc
  • Ask the user

What would be the best cross/platform way of doing this?

Kind of related, Can I depend on bash to be on the majority of *nix or is it distribution/OS dependent?

Target platforms:

  • Mac OS
  • Linux (all distributions)
  • BSD (all versions)
  • Solaris, Minix, and other *nix
Asked By: beatgammit


For the second question, the answer is no and you should have a look at Resources for portable shell programming.

As for the first part – first of all, you certainly have to be careful. I’d say perform several tests to make sure – because the fact that someone does have systemd (for ex.) installed, does not mean it is actually used as the default init. Also, looking at /proc/1/comm can be misleading, because some installations of various init programs can automatically make /sbin/init a symlink hardlink or even a renamed version of their main program.

Maybe the most useful thing could be to look at the init scripts type – because those are what you’ll actually be creating, no matter what runs them.

As a side note, you might also have a look at OpenRC which aims to provide a structure of init scripts that is compatible with both Linux and BSD systems.

Answered By: rozcietrzewiacz
  1. This is what distro-specific packages are for. There is much more to installing software properly than just detecting the init system. Many distros use SysVinit but not all of them write their init scripts the same way. The proper way to solve this is to include all the different variants and then bundle it up using spec files with distro-specific dependency names for rpm distros, deb files for apt based systems, etc. Almost all distros have some sort of package specification you can write that includes dependencies, scripts, init scripts, etc. Don’t re-invent the wheel here.

  2. No. Which brings us back to 1. If you need bash it should be a dependency. You can specify this check as part of your configure scripts, but it should also be in the package descriptions.

Edit: Use flags on your configure script such as --with upstart or --without sysvinit. Pick a sane default, then the scripts that package your software for other distros can choose to run this with other options.

Answered By: Caleb

Using processes

Looking at the output from a couple of ps commands that can detect the various versions of systemd & upstart, which could be crafted like so:


$ ps -eaf|grep '[u]pstart'
root       492     1  0 Jan02 ?        00:00:00 upstart-udev-bridge --daemon
root      1027     1  0 Jan02 ?        00:00:00 upstart-socket-bridge --daemon


$ ps -eaf|grep '[s]ystemd'
root         1     0  0 07:27 ?        00:00:03 /usr/lib/systemd/systemd --switched-root --system --deserialize 20
root       343     1  0 07:28 ?        00:00:03 /usr/lib/systemd/systemd-journald
root       367     1  0 07:28 ?        00:00:00 /usr/lib/systemd/systemd-udevd
root       607     1  0 07:28 ?        00:00:00 /usr/lib/systemd/systemd-logind
dbus       615     1  0 07:28 ?        00:00:13 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation

Paying attention to the name of the process that’s PID #1 can also potentially shed light on which init system is being used. On Fedora 19 (which uses systemd, for example:

root         1     0  0 07:27 ?        00:00:03 /usr/lib/systemd/systemd --switched-root --system --deserialize 20

Notice it isn’t init. On Ubuntu with Upstart it’s still /sbin/init.

$ ps -efa|grep init
root         1     0  0 Jan02 ?        00:00:03 /sbin/init

NOTE: But use this with a bit of caution. There isn’t anything set in stone that says a particular init system being used on a given distro has to have systemd as the PID #1.


$ (ps -eo "ppid,args" 2>/dev/null || echo "ps call error") 
    | awk 'NR==1 || $1==1' | less
    1   /lib/systemd/systemd-journald
    1   /lib/systemd/systemd-udevd
    1   /lib/systemd/systemd-timesyncd

Look at processes with ppid 1 (children of the init process). (Some of the) child process names might point to the init system in use.

The filesystem

If you interrogate the init executable, you can get some info from it as well. Simply parsing the --version output. For example:


$ sudo /sbin/init --version
init (upstart 1.5)
Copyright (C) 2012 Scott James Remnant, Canonical Ltd.

This is free software; see the source for copying conditions.  There is NO warranty; not even for MERCHANTABILITY


$ type init
init is /usr/sbin/init

NOTE: The fact that init is not in its standard location is a bit of a hint/tell. It’s always located in /sbin/init on sysvinit systems.


$ type init
init is /sbin/init

Also this:

$ sudo init --version
init: invalid option -- -
Usage: init 0123456SsQqAaBbCcUu


So there doesn’t appear to be any one way to do it, but you could formulate a suite of checks that would pinpoint which init system you’re using with a fairly high degree of confidence.

Answered By: slm

On Gentoo, take a look at pid 1:

root         1  0.0  0.0   4216   340 ?        Ss    2013   0:57 init [3]

If it is init, then the init system is OpenRC. If it is systemd, then the init system is systemd.

You can detect Gentoo with [ -f /etc/gentoo-release ].

Another method on Gentoo is to use profile-config show, which will show what default profile is in use. All of the profiles except the two ending in /systemd use the OpenRC init. Keep in mind, these are only representative of a default and it is possible that the user has taken steps to override that default and may not be indicative of the init manger actually in use.

Answered By: casey

This is really easy for some init systems. For systemd:

test -d /run/systemd/system

for upstart:

initctl --version | grep -q upstart

for anything else, you can just assume based on the distro (launchd on OS X, sysvinit on Debian, OpenRC on Gentoo).

Answered By: CameronNemo

Sometimes it’s as easy as using ls :

$ ls -l /sbin/init
lrwxrwxrwx 1 root root 20 juin  25 12:04 /sbin/init -> /lib/systemd/systemd

I guess if /sbin/init is not a symbolic link, you’ll have to check further following suggestions in other answers.

Don’t know about other systems then Debian (wheezy) /or Ubuntu (14.10.) but I test such issues with the plain old file command.

file /sbin/init

give this:

/sbin/init: symbolic link to 'upstart'

Debian systems with systemd (e.g. sid) show this:

# file /sbin/init 
/sbin/init: symbolic link to /lib/systemd/systemd
Answered By: zzeroo

I’ve stepped into this problem myself and decided to do some tests. I fully agree with the answer that one should package for each distro separately, but sometimes there are practical issues that prevent that (not least manpower).

So for those that want to “auto-detect” here’s what I’ve found out on a limited set of distros (more below):

  • You can tell upstart from:

    [[ `/sbin/init --version` =~ upstart ]] && echo yes || echo no
  • You can tell systemd from:

    [[ `systemctl` =~ -.mount ]] && echo yes || echo no
  • You can tell sys-v init from:

    [[ -f /etc/init.d/cron && ! -h /etc/init.d/cron ]] && echo yes

Here are my experiments with the following command line:

if [[ `/sbin/init --version` =~ upstart ]]; then echo using upstart;
elif [[ `systemctl` =~ -.mount ]]; then echo using systemd;
elif [[ -f /etc/init.d/cron && ! -h /etc/init.d/cron ]]; then echo using sysv-init;
else echo cannot tell; fi

on ec2 instances (I’m including the us-east AMI id):

  • ArchLinux: using systemd (since 2012.10.06)
  • CentOS6.4 ami-52009e3b: using upstart
  • CentOS7 ami-96a818fe: using systemd
  • Debian 6 ami-80e915e9: using sysv-init
  • Debian 7.5 ami-2c886c44: using sysv-init
  • Debian 7.6 GCE container-vm: using sysv-init
  • RHEL 6.5 ami-8d756fe4: using upstart
  • SLES 11 ami-e8084981: using sysv-init
  • Ubuntu 10.04 ami-6b350a02: using upstart
  • Ubuntu 12.04 ami-b08b6cd8: using upstart
  • Ubuntu 14.04 ami-a427efcc: using upstart
  • Ubuntu 14.10 and younger: using systemd
  • AWS linux 2014.3.2 ami-7c807d14: using upstart
  • Fedora 19 ami-f525389c: using systemd
  • Fedora 20 ami-21362b48: using systemd

Just to be clear: I am not claiming that this is foolproof!, it almost certainly isn’t. Also note that for convenience I use bash regexp matches, which are not available everywhere. The above is good enough for me right now. However, if you find a distro where it fails, please let me know and I’ll try to fix it if there’s an EC2 AMI that reproduces the problem…

Answered By: TvE

On debian /sbin/init is a symlink to your default init so

ls -l /sbin/init

will give you the info you’re looking for.

$ ls -l /sbin/init 
lrwxrwxrwx 1 root root 20 nov 18 13:15 /sbin/init -> /lib/systemd/systemd
Answered By: rmorelli74

Also inspecting file descriptors can help. And it’s from actually running init (Debian stretch currently allow to have more init systems installed) 🙂

$ ls -l /proc/1/fd |grep systemd
lrwx------ 1 root root 64 srp 14 13:56 25 -> /run/systemd/initctl/fifo
lr-x------ 1 root root 64 srp 14 13:56 6 -> /sys/fs/cgroup/systemd

$ ls -l /proc/1/fd |grep /run/initctl # sysvinit
lrwx------ 1 root root 64 srp 14 14:04 10 -> /run/initctl

$ ls -l /proc/1/fd |grep upstart
l-wx------ 1 root root 64 srp 13 16:09 13 -> /var/log/upstart/mysql.log.1 (delete
l-wx------ 1 root root 64 srp 13 16:09 9 -> /var/log/upstart/dbus.log.1 (deleted)

$ ls -l /proc/1/fd # busybox
total 0
lrwx------    1 root     root          64 Jan  1 00:00 0 -> /dev/console
lrwx------    1 root     root          64 Jan  1 00:00 1 -> /dev/console
lrwx------    1 root     root          64 Jan  1 00:00 2 -> /dev/console

Probably safer way to check for busybox would be to check /proc/1/exe, as busybox usually uses symlinks:

$ ls -l /proc/1/exe 
lrwxrwxrwx    1 root     root          0 Jan  1 00:00 /proc/1/exe -> /bin/busybox

So check could be:

{ ls -l /proc/1/fd |grep -q systemd && echo "init: systemd"; } || 
{ ls -l /proc/1/fd |grep -q /run/initctl && echo "init: sysvinit"; } || 
{ ls -l /proc/1/fd |grep -q upstart && echo "init: upstart"; } || 
{ ls -l /proc/1/exe |grep -q busybox && echo "init: busybox"; } || 
echo "unknown init"
Answered By: pevik

Simply greping into the process with PID 1 will tell you:

strings /proc/1/exe |grep -q sysvinit
strings /proc/1/exe |grep -q systemd
Answered By: Cyrille Pontvieux

Here’s a bash script to do the detection. It only checks for upstart and systemd at the moment, but should be easy to extend. I’ve taken this from code I’ve contributed to the DisplayLink driver install script.

  # init process is pid 1
  INIT=`ls -l /proc/1/exe`
  if [[ $INIT == *"upstart"* ]]; then
  elif [[ $INIT == *"systemd"* ]]; then
  elif [[ $INIT == *"/sbin/init"* ]]; then
    INIT=`/sbin/init --version`
    if [[ $INIT == *"upstart"* ]]; then
    elif [[ $INIT == *"systemd"* ]]; then

  if [ -z "$SYSTEMINITDAEMON" ]; then
    echo "WARNING: Unknown distribution, assuming defaults - this may fail." >&2
    echo "Init system discovered: $SYSTEMINITDAEMON"
Answered By: Ben McCann

There is a lot of compatibility pitfalls when testing systemd vs initd. This actually works on OpenSuSE 42.1: ps --pid 1 | grep -q systemd && echo 'systemd' || echo 'init'

Answered By: David Lakatos

I also had this same problem, and did a lot of tests in some RedHat/CentOS/Debian/Ubuntu/Mint machines. This is what I ended up with, with good results.

  1. Find the name of the executable with PID 1:

    ps -p 1

    If it’s systemd or Upstart, problem solved. If it’s “init”, it may be a symlink or something other than an upfront name. Go ahead.

  2. Find the real path for the executable (only work as root):

    ls -l `which init`

    If init is a symlink to Upstart or systemd, problem solved. Otherwise, it’s almost certain that you have SysV init. But it can be a misnamed executable. Go ahead.

  3. Find the package which provides the executable. Unfortunately, this is distro-dependent:

    dpkg-query -S (executable real path) # Debian  
    rpm -qf (executable real path) # RedHat  

Then, if you want to script that (the funniest part, IMHO), these are my one-liners (run as root):

ls -l $(which $(ps -p 1 o comm)) | awk '{ system("dpkg-query -S "$NF) }' # Debian  

ls -l $(which $(ps -p 1 o comm)) | awk '{ system("rpm -qf "$NF) }' # RedHat  
Answered By: Emerson Prado

Not that efficient but I it seems to work.

strings /sbin/init | grep -q "/lib/systemd" && echo SYSTEMD
strings /sbin/init | grep -q "sysvinit" && echo SYSVINIT
strings /sbin/init | grep -q "upstart" && echo UPSTART

It will print more lines if more than one strings match, which could be translated to "Can’t guess". Strings used in grep could be slightly modified but when tested in the following os I always got one line.

  • RHEL 6.4 [UPSTART]
  • RHEL ES 4 (Nahant Update 7) [SYSVINIT]
  • Ubuntu 16.04.1 LTS [SYSTEMD]
  • Ubuntu 14.04.2 LTS [UPSTART]
  • Fedora release 23 (online shell) [SYSTEMD]
  • Debian GNU/Linux 7 (online shell) [SYSTEMD]
  • Centos 7.6 (VM) [SYSTEMD]

A more simplistic approach of the same solution (but it stops at first match)

strings /sbin/init |
  awk 'match($0, /(upstart|systemd|sysvinit)/) { print toupper(substr($0, RSTART, RLENGTH));exit; }'


As KCGD points out many systems don’t come with strings installed. So a more portable alternative could be:

cat /sbin/init | 
  awk 'match($0, /(upstart|systemd|sysvinit)/) { print toupper(substr($0, RSTART, RLENGTH));exit; }' 2> /dev/null
Answered By: Marinos An

For systemd:

if [[ `systemctl is-system-running` =~ running ]]; then echo using systemd; fi
Answered By: guilhermebr

My solution: check the command running as process with ID 1.

case `cat /proc/1/comm` in
    init)    echo Init ;;
    systemd) echo SystemD ;;
    # add here other patterns
    *)       echo "unknown: '`cat /proc/1/comm`'" ;;

At the moment I have access only to Init and SystemD machines, so I can’t Tell how Upstart or macOS (OS X) will be detected, but I’ll keep searching.

Answered By: t0r0X
    if hash systemctl 2>/dev/null;
        echo "there is systemd"

    if hash initctl 2>/dev/null;
        echo "there is upStart"

    if [ -f "/etc/inittab"];
        echo "there is systemV"
Answered By: hxysayhi

How’bout this one :

strings $(ps -p 1 o cmd= | cut -d" " -f1) | egrep -o "upstart|sysvinit|systemd" | head -1

Only tested on the systems I have: Ubuntu and SailfishOS.

Answered By: SebMa

I would use pstree and simply find its root. On my Ubuntu, Arch and Fedora systems (unfortunately all use systemd for init), running pstree gives me the following output head:

        |         `-8*[{GUIPool}]
        |-MainThread-+-Privileged Cont---29*[{Privileged Cont}]
        |            |-Web Content---30*[{Web Content}]
        |            |-Web Content---32*[{Web Content}]
  1. So, as a simple solution using pstree, head and cut which are come preinstalled on most systems, I’d run pstree | head -n 1 | cut -d "-" -f 1,1
    It threw the needed string "systemd" at me on all three OSs I tested it on.
  2. Alternately, you could run something like
    pstree | head -n 1 | ([[ $(grep systemd) ]] && echo systemd) || ([[ $(grep upstart) ]] && echo upstart) || ([[ $(grep sysvinit) ]] && echo sysvinit)
Answered By: computronium

My ultimate solution.

As upstart seem dead and I don’t them anywhere, I’m not able to test what’s happen if I hit ps -C upstart on upstart based host.

Trying different ps 1 was definitively not efficient in all my tested hosts…

My purpose is finally:

if ps -C systemd | grep -q '^ *1 ' ;then
    echo This system run systemd
    echo This system run init

Check to see if my system has systemd available

For anyone wondering if your system has systemd, not if it was booted by systemd, these are the easiest commands I could come up with. I’m using this to test if my custom embedded Linux board successfully got systemd onto it from Buildroot:

# best: check the systemd-run version
systemd-run --version

# or: look for any "systemd" files or folders on your computer
find / | grep -i systemd | sort -V

# or: look for "systemd" files in /usr/bin
find /usr/bin | grep -i systemd | sort -V

For my board, I get the following output:

1st command:

# systemd-run --version
systemd 244 (244)

My makefile in Buildroot shows SYSTEMD_VERSION = 244.3, so this makes sense.

2nd command:

It’s too long for me to care to copy/paste it all, but it shows entries in /usr/lib/systemd, /usr/bin/systemd*, etc.

3rd command:

# find /usr/bin | grep -i systemd | sort -V

This is the list from which I found the systemd-run executable. I simply guessed that running systemd-run --version might work, and sure enough, it did!

See also

  1. Super User: How to know if I am using systemd on Linux?
  2. Convenient way to check if system is using systemd or sysvinit in BASH?
Answered By: Gabriel Staples
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.