Ubuntu very slow boot while detecting devices

Booting up Ubuntu 24.04 spends a very long time (around two minutes) while apparently detecting various USB devices.

I have tried to identify the devices printed out during this slow process and attempted to disable their detection and load, by adding their blacklist designations to /etc/modprobe.d/blacklist entries, but that did not change the behaviour I see. After adding to the blacklist, I recreated the initrd with sudo initramfs -u and then hardware-rebooted.

Here’s the video of a boot-up before making any changes: https://youtu.be/tBt5mqwwOCo

Here’s the video of a boot-up after blacklisting appleir, appleir_hid, ohci-pci, ohci-firewire and ohci: https://www.youtube.com/watch?v=tBt5mqwwOCo

As you can see, my change actually made the boot process slower. So, maybe that wasn’t a good guess.
In the initial video after the hang releases, you can see an error message about the the "tsc" clocksource unstable because of a detected clock skew.
Whereas, after my change you can see a new message, where it says "workqueue: hub_event hogged CPU for >10000us 4 times, consider switching to WQ_UNBOUND"

I do not understand whether either of these messages are something that I can recover from as an installer/user.

Running systemd-analyze simply tells me that the kernel took 4.7s to start.

Asked By: Douglas Held

||

Solution to this was to try earlier Ubuntu releases. I replaced with Elementary Linux 7.1. Problem solved for now!

https://linux-hardware.org/?probe=cbccdbbf42

Answered By: Douglas Held