Ubuntu 22.04 not opening in GUI

I had some problems updating my old 20.04 to 22.04.
After my initial update my kernel was still at 5.4.0-174.

My system was starting but not everything was working.
I’ve upgraded my kernel using the command apt-get install linux-image-generic-hwe-22.04

After the upgrade it looks like the system is starting. But after a while the screen gets blank with a cursor. You cannot do anything anymore.

Opened another terminal using shift, alt , F2 and did a reboot to safemode. From safemode I can get to normal boot.

I’ve tried sudo apt install –reinstall ubuntu-desktop but that did not solve the problem.

In the messages passing by I saw Grub failed boot detection.

Any help?

Asked By: Mantaraya

||

Update,

I solved it by changing my NVIDA proprietary driver.
I’ve changed it to X server -Nouveau display driver from xserver-xorg-video-nouveau

Answered By: Mantaraya
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.