Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages, specific package can not be removed

Edited for more context.
The suggested links to fix the issue focus on removing the broken package. If I try to remove the sysvinit-utils package I get the output as indicated below (the long list of dependencies of lsb-base) and the remove fails. So the suggested link does not resolve it, I have tried the several additional options like removing the package with dpkg directly and the same happens. So I’m stuck in a loop.

Suggested duplicate link
This link does not fix it, please look at the content of my request and you will see that this is a "simple" non-essential package that would need to be removed. It does not fix my issue, hence the reason I opened this request.

I wanted to update smartmontools to 7.4 in Ubuntu 22.04 (It is not for ubu22, version 7.4 is not available) so I installed the latest version using dpkg and then several dependencies were needed so I installed also the latest version of sysvinit-utils (3.08-6ubuntu2, again not for ubu22), then the dependency of libc6 and I do not want to do that due to additional dependencies. So in trying to revert the changes I run into the following issue:

Now when I want to run apt upgrade I get this:

sudo apt upgrade
[sudo] password for niels:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 sysvinit-utils : Depends: libc6 (>= 2.38) but 2.35-0ubuntu3.6 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So I run it and get:

sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 sysvinit-utils : Depends: libc6 (>= 2.38) but 2.35-0ubuntu3.6 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I can’t downgrade the sysvinit-utils to the previous version:

sudo apt install sysvinit-utils=3.01-1ubuntu1
[sudo] password for niels:
Sorry, try again.
[sudo] password for niels:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 acpid : Depends: lsb-base (>= 3.2-14)
---snip---
 unattended-upgrades : Depends: lsb-base
 x11-common : Depends: lsb-base (>= 1.3-9ubuntu2)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I’ve tried to do what is suggested here and I keep getting back to the same issue:
How to downgrade a package via apt-get?

Any suggestions on how to fix this?

Asked By: Niels Sommer

||

Fixed it.

Removed the partially installed smartmontools package, installed lsb-base package, then downloaded sysvinit-utils_3.01-1ubuntu1_amd64.deb, installed it and back to normal.

I can update/upgrade.

Answered By: Niels Sommer
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.