Ubuntu 20.04 – Kernel Panic when installing AMD Drivers

First post here, so be gentle…

I’m installed Ubuntu 20.04 Desktop onto an old desktop turned mining rig. I managed to install Ubuntu onto the HDD currently in the system, and works seamlessly, until I get to the driver installation for my AMD cards. I have 7 RX 480s that I intend on using on this PC, but all are removed for this install bar one. It should be noted that this rig had CentOS and HiveOS on it beforehand, not at the same time, mainly for testing purposes.

I tried installing the offical drivers for 20.04 onto this system but everytime I install the driver, I get a kernel panic, followed by a white screen of death, telling that something has gone wrong, and that the system is unusable.

After trying the fixes from this post, I was forced to reinstall 20.04, then to try and install open source drivers provided by oibaf. These drivers install just fine, but when I try and mine with these, I get the same kernel panic as before, and the system becomes unusable yet again. I’m basically back at square one.

This is the exact error I’ve been getting.

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I had originally gone with Ubuntu 22.04 Desktop, but the official AMD drivers refused to install, even though these drivers are for 22.04, thus putting me back at square one, yet again. From what I’ve read online, there’s better support on 20.04 then there is with 22.04.

I’ve tried installing a different GPU in the hopes that the card might be faulty, but I still get the same result. I tried an newer SSD, but this gets the same results. I also verified that the GPU VBIOS was still good, but yet again, I get the same result.

Any assistance would be greatly appreciated!

Thanks for viewing!

Asked By: GipsyD

||

Not a really an answer, but I figured I might add this for future viewers and troubleshooters. After 7 days of trial and error, this is what I came up with.

So, the way I got around this was downgrading to Ubuntu Desktop 18.04. Once downgraded, I then used AMD Driver 21.50 found at the link below –

https://repo.radeon.com/amdgpu-install/21.50/ubuntu/bionic/

This driver works flawlessly with 18.04, and installs OpenCL, Vulkan and ROCM. It should be noted that this driver, while older, does not throw a Insecure Repository error, like 21.40 did. I installed the .deb through 18.04’s package installer, as a bit of automation.

This github link also helped a lot, linked below –

https://github.com/gmorningman/ubuntu-crypto-mining-server?tab=readme-ov-file

Note that this is for Ubuntu Server 18.04, but the installation steps are still the same. I also didn’t use all of the steps, as these steps were either irrelevant, or were automatically catered for by 18.04.

22.04 is not AMD friendly, though it is very Nvidia friendly.

Answered By: GipsyD