Ubuntu 22 – Repeated wireless reset by kernel

I have a baffling issue on a relatively fresh install of ubuntu 22.04. I noticed today that the internet was very slow on my laptop, but not on my phone or other laptops in the apartment. After some investigating, I noticed that any time the network connection went down, I had a process called kworker/28:2+events using 100% CPU when I ran top.

After checking /var/log/kern.log, I noticed that there was a message in there every time the kworker process popped up:

... ieee80211 phy0: Hardware restart was requested

This seems to happen every time I try to make any kind of connection. Further more, and somewhat unexpectedly, whenever I run a sudo command while the kworker process is active, the sudo command hangs until the kworker process finishes.

My understanding is that these kinds of issues generally relate to the kernel and some kind of bug within it. I notice on my software updater that there are kernel updates available, so I obviously want to try to get those updates, but… when I try to do that, I get hit with the hardware reset issue.

I am desparate to get this fixed as soon as possible, but I have no idea where to go from here. Any ideas?

Asked By: wvn

||

The Intel AX210 Wireless card is relatively new, in late 2020. The driver kernel modules have been improved the last years. The kernel module that provides Intel wireless networking is named iwlwifi. There are some options that can be set for this module that can change it’s behavior. You can disable bluetooth, which uses the same 2.4Ghz, but hardly interfers with Wifi. Or disable the watchdog that monitors the transmission queues.

The Intel AX210 is a Wifi 6E capable module that supports 802.11AX and can use the faster 6Ghz if your accesspoint supports it. An access point can run multiple wifi standards for backwards compatibility. This however can also make networks unstable and disabling the older protocols like G and N can help make the network more stable on the 2.4Ghz frequencies.

Great to hear that the kernel update and disabling of 11n helped, you did well!

Answered By: sleepyhead
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.