WiFi Issue: Terminal Freeze upon Turning Off WiFi

Dear Ubuntu Community,

I am encountering a persistent issue with my Ubuntu 23.10 system related to the WiFi functionality. While the WiFi connection itself works flawlessly, attempting to turn off the WiFi leads to the entire system freezing. Any commands involving sudo or NetworkManager result in the terminal becoming unresponsive.

Upon investigating the system logs using journalctl, I consistently encounter the following error message:

kernel: iwlwifi 0000:02:00.0: Queue 5 is active on fifo 3 and stuck for 10000 ms. SW [6, 7] HW [7, 7] FH TRB=0x080305006

In an attempt to resolve this issue, I followed a solution suggested on Ubuntu Ask, which involved modifying the GRUB configuration. The steps I followed were:

Opened the GRUB configuration file using the command: sudo nano /etc/default/grub.
Modified the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to include net.ipv4.tcp_ecn=0.
Saved the changes (Ctrl+o) and exited nano (Ctrl+x).
Updated GRUB using the command: sudo update-grub.

However, despite implementing this solution, the problem persists, and the same error continues to occur.

Further investigation led me to another potential solution involving checking the integrity of the firmware file iwlwifi-3160-17.ucode. However, I encountered a discrepancy as I found that the file on my system is named iwlwifi-3160-17.ucode.zst, and the hash I obtained (efa40dcbabe15f74f4763d7534419752) differs from the expected hash (fee0d7dddf8437148ab25c4b1a34202c).

Additionally, I attempted to execute the command sudo sysctl -w net.ipv4.tcp_ecn=0 as part of a different solution, but unfortunately, it did not resolve the issue.

I noticed that if I turn the WiFi off and on using the command sudo systemctl stop NetworkManager and then sudo systemctl start NetworkManager, it works perfectly fine without causing any system freeze.

One more thing to note is that when using a bootable USB to run Ubuntu in ‘Try Ubuntu’ mode without installing, I can turn the WiFi on or off normally without encountering this issue. I faced this error in Ubuntu 22, and after erasing all my data and installing Ubuntu 23, I encountered the same error.

Thank you for your attention and support.

Asked By: David Koyno

||

Kernel version 6.7.0+ seems to fix this issue.

I’ve been experiencing this issue as well since Nov-Dec 2023 until February 2024 (I ran Arch Linux at that time), where turning off WiFi via GUI, rfkill, NetworkManager (systemctl and nmcli), airplane mode, all freeze the system and I have to force shutdown, rfkill unblock all, and then reboot again to make the WiFi work. My journalctl also shows iwlwifi gets stuck on fifo queue

I tried adding some parameters to /etc/modprobe.d/iwlwifi.conf, also tried your solution (sudo sysctl -w net.ipv4.tcp_ecn=0), none of them worked

Only until recently (the middle of February if I remember correctly), kernel version 6.7.0 went live and I can finally disable WiFi without the whole system freezing

Now I run Pop!_OS 22.04 LTS with kernel version 6.6.10 and I’m having this problem again.

Answered By: easyGram

I faced the same problem on Ubuntu 22.04 with 5.15.0-101-generic kernel. I tried to downgrade the kernel to 5.15.0-100-generic and 5.15.0-97-generic, but the issue remained.
Switching to the latest HWE 6.5.0-26-generic doesn’t help too.

Then I rolled back the entire system to March 19th, but without any success. Then to the state of March 12th (thanks to TimeShift!) and bingo! Now it’s working.

The kernel version is 5.15.0-97-generic, which I tried already without rolling back everything else. So it looks like the problem is not in kernel changes.

Update

After rollback I tried to install updates one-by-one (in small groups of related) and installed all available updates without any trouble. Then checked kernels:

  • 5.15.0-100-generic — does not work
  • 5.15.0-101-generic — does not work
  • 6.5.0-26-generic — does not work
  • 5.15.0-97-generic — works well!
  • 6.5.0-21-generic — works well!

Though I’ve no idea why 97 didn’t work when I first time tried to downgrade the kernel. The bug is reported, but there is no noticeable activity.

Answered By: Snaker