Noise when initiating play with handsfree

A loud tikk sound is played when starting with handsfree.

In each use of handsfree this problem occurs only once.

I don’t have that problem with the speaker.

Audio:
 Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
 Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
 API: ALSA v: k6.6.15-amd64 status: kernel-api
 Server-1: PipeWire v: 1.0.3 status: active
Asked By: fsgdfgdfgd

||

Solved with

sudo bash -c ' echo options snd_hda_intel power_save=0 > /etc/modprobe.d/audio_disable_powersave.conf'

After combing through numerous forum posts and websites, I learned the root cause of the issue. It is because of capacitor discharge in the handsfree port(or speakers). And it can be solved by turning off the power-saving setting of a sound card.

By turning off power saving, you are allowing the system to charge those capacitors when they get discharged. It is similar to using a phone while charging constantly.

*

https://itsfoss.com/buzzing-noise-speaker-linux/
Answered By: fsgdfgdfgd
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.