Network settings seems to be completely broken, no logic to be seen

I have been a random problem with my server for a while, every now and then after a reboot the network suddenly completely stops working. Normally, after a few changes in the network files I am eventually able to get it back. But today I have tried everything and don’t seem to be able to fix it.

All settings seem correct to me. Running Ubuntu 22.04, always been able to connect by SSH from my local laptop. Currently unable to connect by SSH, unable to ping any host, even localhost ping is failing. Usually on a static ip, also tried a dynamic IP and actually received one from the DHCP server.

Now back on the static IP settings, will share some data below:
(cannot copy paste from VMware ESXi)

netplan .yaml
https://prnt.sc/YBlOtObRiczD

netplan –debug apply
https://prnt.sc/KOWv9JjkfpAL

netplan status
https://prnt.sc/XHnJiq_pW1pl

resolv.conf
https://prnt.sc/XFyiMvqb5qRQ

ip a
https://prnt.sc/4Hdcs6dxs8iD

ip route
https://prnt.sc/FtMONPO41tY9

arp
https://prnt.sc/unl5qerSyWZD

When trying to ping it doesn’t work in any case, it just ‘hangs’; localhost, 127.0.0.1, 192.168.0.1 or 8.8.8.8
https://prnt.sc/6paaUgBkgi6j

Does anyone have a clue whats going on with this machine? I have been unable to make any sense of this. All other machines on the VMWare are working correctly. Thanks in advance!

Asked By: Yoshi

||

FIXED: There were no problems with the network settings. Before encountering this problems the disk spaces got full, I extended the volumes but it didn’t fix. I have deleted the directory which got the disk full, and after that the network got up in a magic way. Seems like there was some corruption on the disk or something..

Answered By: Yoshi
Categories: Answers Tags: , , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.