Unable to boot into Live-USB and always restart (22.04/23.10, Lenovo Legion R9000P 2023)

Currently I have series problem when preparing dual-boot Ubuntu 22.04.3 Desktop (Linux Kernel 6.2, link of ISO), Ubuntu 22.04.3 Server (link of ISO) and Ubuntu 22.04.1 (Linux Kernel 5.15, link of ISO). LiveCD just failed to boot (seems to be stopped and rebooted when loading services, and thus X11 window is not loaded).

Figure on booting Ubuntu 22.04.3 LiveCD

↑ Laptop will stay at this stage for about 10 sec, then reboot ↑

Last Outputs found in Ubuntu 22.04.1 LiveCD (for the first time booting into LiveCD; for the second time, (x of 5) may not show on screen):

Started CUPS Schedular.
Started Network Manager Script Dispatcher Serivce.
Finished Detect the available GPUs and deal with any system changes.
(1 of 5) A start job is running for Ubuntu live CD installer (19s / no limit)
(2 of 5) A start job is running for Network Manager Walt Online (21s / no limit)
(3 of 5) A start job is running for casper-md5check Verify Live ISO checksums (28s / no limit)
(4 of 5) A start job is running for Dispacher daemon for systemd-networkd (30s / 1min 35s)
(5 of 5) A start job is running for Snap Daemon (32s / 1min 35s)

It soon reboots (about 34s, instead of running out 1min 35s).

Additional notes for Ubuntu 22.04.3 Server:

  • Could boot to installation interface by 1) boot into rescue mode, i.e., add 1 to grub linux; 2) then exit rescue mode.
  • Stuck about 10 seconds in options for network, then automatically reboot. So I guess something failed for network service (either NetworkManager or systemd-networkd).

Hardware and Software specifications:

  • Lenovo Legion R9000P ARX8 (2023); AMD Ryzen 9 7945 HX (Zen 4).
  • No secure boot, UEFI mode. USB prepared by rufus-4.3 (GPT, UEFI no CSM, ISO mode instead of DD mode) or UltraISO.
  • Windows 11 pre-installed and work fine.
  • Have installed Ubuntu 22.04 once before (but found boot problems afterwards). While attempting to reinstall Ubuntu, I found I could not even boot into LiveCD. Since I have formatted previous Ubuntu, now I can’t boot into rescue mode (sad QAQ).
  • Power management seems to be controled by softwares in Windows. Quiet and normal modes are utilized, while performance/extreme mode is not applied during booting LiveCD.

Attempts tried thus far:

  • Tried out various BIOS option combinations for wireless availability, switchable/discrete GPU mode, memory/CPU/GPU overclocking, VT, AMD security, …, still not working.
  • BIOS of my computer does not have ACHI option. So (maybe) I can’t change that currently. But since this laptop only accepts NVME SSDs, I guess it’s already ACHI.
  • Grub option combinations acpi=off noapci noirq nomodeset tried, so seems not (or not only) an ACPI problem.
  • Tried out other distributions, such as Ubuntu 23.10.1 (not the legacy one), Fedora 39, ArchLinux 2023.11.01. They behave similarly (reboot when starting services around network). ISO SHA256SUMS checked for Ubuntu 22.04.1 and 22.04.3 Desktop.
  • Also tried out different USB ports (USB-3.0, USB-2.0). I currently have only one USB stick, so I could not verify whether it’s the problem of the USB stick.

Hope someone could point out the what’s the problem! Many thanks!

Asked By: ajz34


I’m trying to answer my own question, since a temporary resolution found.

Probably a compatibility problem of ethernet hardware/software (PCIe) for dual-boot systems of Linux and Windows.

This problem may link to another thread: X670 Elite AX WiFi/BT (RZ616) is not available on 22.04 but somewhat different. The wifi hardware of my laptop happens to be the same to that thread (RZ616). What makes different is that instead of wifi connection not working, my laptop just crashes and reboot (either starting NetworkManager service or run dhclient).

After running dhclient, I found that problem is more likely to be RTL8111/8168/8411 PCIe (stuck and reboot when dhclient enp7s0, where enp7s0 could be inferred by lshw -c network or lspci). Though tried out some solutions in Ubuntu 20.04 Ethernet R8168, roll back driver to r8168-dkms may still failed to boot if laptop power not completely removed.

Solution 1: Completely remove power.

Okay, this seems a bit absurd, but the solution here was to shutdown, disconnect my computer from power for a few minutes, reconnect the power cable, then reboot.

So in this case, before booting into LiveCD or into Ubuntu OS, make sure power has been completely removed. Since laptop (battery + cable) is not the same to computer (cable only), one may perform:

  • A hard shutdown or reboot (pressing power button 8-15 sec)
  • For this laptop, entering BIOS to disable built-in battery (perhaps a better way imposing less damage to motherboard)

Solution 2: Disable ethernet driver RTL8111/8168/8411.

For dual-boot laptop, if one does not need ethernet connection, then disable the RTL8111/8168/8411 driver in either Windows or Linux could resolve this problem.

  • In Windows, disable Realtek PCIe GbE Family Controller;
  • In Linux, disable driver by rmmod r8168 or rmmod r8169, depending on the driver installed.

By this way, both Windows and Linux systems are able to be booted, without the need to remove power.

Answered By: ajz34
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.