Ubuntu not present in GRUB after update to 23.10

I’ve a dual-boot with kUbuntu and Windows 10. I had a GRUB configuration made with Grub Customizer tool (auto boot after 10s, theme). And it worked really well.
Today I updated Ubuntu from 23.04 to Ubuntu 23.10. During update I decided to keep my current GRUB profile. After update the entries of Ubuntu are completely missing. I’ve old settings (theme, and so on) and rest of the entries (Windows, Memtest and UEFI), but Ubuntu entry and Ubuntu Advanced Options are missing. It’s the first time it happened to me and I’ve been using such dual-boot config (made with Grub Customizer) on multiple computers for some years.
What happened and how can I fix it?

I can go to GRUB’s CLI and can boot to Windows, but I have no idea how can I access Ubuntu to try doing something like update-grub.
Can I fix it using this GRUB’s CLI or Live USB?

Some information about my setup and what I’ve tried.
I got Windows installed on nvme0 and got efi partition there with Windows Boot Manager. (I usually do not overwrite it but install grub elsewhere to be able in case of somethink to simply choose to boot Windows Boot Manager).
I got kUbuntu installed on sda and did not manually created the efi partition. Got there only sda1 – wpar and sda2 – linux filesystem (which has /boot and /boot/efi dirs and).
I mounted sda2 in /mnt using liveUSB and chroot into it. I was able to run update-grub but it only found the entries I already have (Windows, Memtest, UEFI) and not Ubuntu.
I’ve tried to reinstall grub there. But grub-install returned an error that it cannot find efi partition and when I pointed /mnt/boot/efi as efi-path and got another error that this is not a valid efi partition.
Have anyone some ideas how can I reinstall it?

Asked By: Aenye_Cerbin


I have a really old Fujitsu laptop. Over the years I have upgraded this laptop several times to latest and greatest ubuntu rekease. Upgrade to 23.04 was a disapointment. Refused to boot because of nvidia 390 problems. Had to wipe nvidia. Now upgraded to 23.10. New problem. Not booting. Even worse than last time. After upgrade completed finally, took forever to search for old software, it asked to reboot. I did and went into bios setup…So I had to boot from live usb stick with 23.10, try option and install boot-repair from 23.04. Not present for 23.10. That made the system boot. Finally…..

Answered By: Jan Wester

Fixed using Boot-Repair, but it required to manually purge some GRUB files, because the tool was not able to do it automatically.

Answered By: Aenye_Cerbin

I forgot to mention that I am still not satisfied. Yes, using boot-repair made my system boot again. Yes. But boot-repair was not hassle free. It required several manual steps. Copy and pasting lots of commands. And after all of this I still cannot get grub into graphics mode. But it boots.. Both windows and ubuntu. So basic steps working yes. So only way now is to set grub to console mode not to what worked before:, graphics mode. So to circumvent that I changed -i to -d in the linux options. It boots as said, but with blue background in g rub menu

Answered By: Jan Wester
Categories: Answers Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.