No internet/bluetooth connection after running apt-get upgrade, and performing autoremove

yesterday evening, after finishing my work I decided to run updates on my pc. I run:
sudo apt-get update
sudo apt-get upgrade

and then I was prompted, that some of the files can be autoremoved, so I just copied suggested command and pressed enter. Everything was working fine, so I shutdown my PC.

Today I noticed that I don’t have internet access, and that bluetooth is not working. I tried to visit different websites, ping different addresses, check for updates – everything was saying that there is no internet access. My wireless headphones were also not working, because there was no bluetooth. I also noticed that both internet and bluetooth icons are not available in top right corner anymore.

no internet and bluetooth icon

The PC is connected to the internet using ethernet cable, and I do have internet on Windows (same PC), but not on Ubuntu. I assume that this autoremoving stuff recommended by Ubuntu did remove some important files, but I’m not sure how to investigate that.

I tried reinstalling network-manager using live-usb, but that did not help.

Below I will paste the result of running commands suggested in comments:

lspci -nnk | grep 0280 -A3
05:00.0 Network controller [0280]: Intel Corporation Wireless-AC 9260 [8086:2526] (rev 29)
    Subsystem: Intel Corporation Wireless-AC 9260 [8086:0014]
06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 26)
    Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1043:87c3]


sudo dpkg -s linux-modules-extra-$(uname -r) | grep Status
dpkg-query: package 'linux-modules-extra-6.2.0-36-generic' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files.

As you can see the second command failed, so I checked how far I can go using tab suggestions, and here is the output:

~$ sudo dpkg -s linux-modules-extra-
linux-modules-extra-6.2.0-1001-ibm     linux-modules-extra-6.2.0-1007-ibm     linux-modules-extra-6.2.0-1011-azure   linux-modules-extra-6.2.0-1016-gcp
linux-modules-extra-6.2.0-1003-aws     linux-modules-extra-6.2.0-1007-oracle  linux-modules-extra-6.2.0-1011-gcp     linux-modules-extra-6.2.0-1017-gcp
linux-modules-extra-6.2.0-1003-azure   linux-modules-extra-6.2.0-1008-aws     linux-modules-extra-6.2.0-1011-oracle  linux-modules-extra-6.2.0-1018-gcp
linux-modules-extra-6.2.0-1003-ibm     linux-modules-extra-6.2.0-1008-azure   linux-modules-extra-6.2.0-1012-aws     linux-modules-extra-6.2.0-20-generic
linux-modules-extra-6.2.0-1003-oracle  linux-modules-extra-6.2.0-1008-gcp     linux-modules-extra-6.2.0-1012-azure   linux-modules-extra-6.2.0-23-generic
linux-modules-extra-6.2.0-1004-ibm     linux-modules-extra-6.2.0-1008-ibm     linux-modules-extra-6.2.0-1012-gcp     linux-modules-extra-6.2.0-24-generic
linux-modules-extra-6.2.0-1005-aws     linux-modules-extra-6.2.0-1008-oracle  linux-modules-extra-6.2.0-1012-oracle  linux-modules-extra-6.2.0-25-generic
linux-modules-extra-6.2.0-1005-azure   linux-modules-extra-6.2.0-1009-aws     linux-modules-extra-6.2.0-1013-aws     linux-modules-extra-6.2.0-26-generic
linux-modules-extra-6.2.0-1005-gcp     linux-modules-extra-6.2.0-1009-azure   linux-modules-extra-6.2.0-1013-gcp     linux-modules-extra-6.2.0-27-generic
linux-modules-extra-6.2.0-1005-ibm     linux-modules-extra-6.2.0-1009-gcp     linux-modules-extra-6.2.0-1013-oracle  linux-modules-extra-6.2.0-31-generic
linux-modules-extra-6.2.0-1005-oracle  linux-modules-extra-6.2.0-1009-ibm     linux-modules-extra-6.2.0-1014-aws     linux-modules-extra-6.2.0-32-generic
linux-modules-extra-6.2.0-1006-aws     linux-modules-extra-6.2.0-1009-oracle  linux-modules-extra-6.2.0-1014-azure   linux-modules-extra-6.2.0-33-generic
linux-modules-extra-6.2.0-1006-azure   linux-modules-extra-6.2.0-1010-aws     linux-modules-extra-6.2.0-1014-gcp     linux-modules-extra-6.2.0-34-generic
linux-modules-extra-6.2.0-1006-ibm     linux-modules-extra-6.2.0-1010-azure   linux-modules-extra-6.2.0-1014-oracle  linux-modules-extra-6.2.0-35-generic
linux-modules-extra-6.2.0-1006-oracle  linux-modules-extra-6.2.0-1010-gcp     linux-modules-extra-6.2.0-1015-aws     linux-modules-extra-6.2.0-36-generic
linux-modules-extra-6.2.0-1007-aws     linux-modules-extra-6.2.0-1010-ibm     linux-modules-extra-6.2.0-1015-azure   linux-modules-extra-aws
linux-modules-extra-6.2.0-1007-azure   linux-modules-extra-6.2.0-1010-oracle  linux-modules-extra-6.2.0-1015-oracle  linux-modules-extra-azure
linux-modules-extra-6.2.0-1007-gcp     linux-modules-extra-6.2.0-1011-aws     linux-modules-extra-6.2.0-1016-azure   linux-modules-extra-gcp

What else can I do to find what the issue is exactly?

Here is a screenshot with information about hardware and OS version:
hardware and os version

Asked By: gkocik


Please try booting into an earlier kernel at the GRUB menu; perhaps -35 or -34, etc. Does the wireless work in an earlier kernel? If so, do:

sudo apt update && sudo apt install --reinstall linux-modules-extra-6.2.0-36-generic 

Reboot and, assuming that the wireless and ethernet are working, reinstall the packages upon which -extra depends:

sudo apt update
sudo apt install --reinstall linux-modules-6.2.0-36-generic wireless-regdb

You should be all set.

Answered By: chili555
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.