Ubuntu 22.04 stuck in power saver mode

I’m on a fresh install of Ubuntu 22.04.3 LTS. I noticed that I cannot toggle out of Power Saver mode. When I choose either Performance or Balanced, it immediately switches back to Power Saver.

I’ve tried using powerprofilesctl set balanced to manually set it and it seems to work fine (no error messages), but it doesn’t seem to change anything as powerprofilesctl list still says it’s in the power-saver profile.

I’ve also tried updating the kernel to the latest mainline (6.5.7-060507-generic) for other reasons, but this did not seem to affect the power settings.

Lastly, I’ve tried disabling the various power saving settings one-by-one in the BIOS but that had no effect.

I am currently running on a Lenovo Thinkpad P14s Gen 4 with an AMD Ryzen 7 PRO 7840U, plugged into a USB4 dock.

How can I ensure that my CPU is not being throttled? Should I be using tlp over powerdaemon (if so, is there a guide for this?)?

Update: I upgraded to 23.10 and it seemingly worked fine. But after some time, it reverted to the problematic behavior and I cannot figure out why yet.

Asked By: Kevin Evans


I’m having the same issue with the same laptop and Ubuntu 23.10. According to this article (https://www.phoronix.com/review/thinkpad-p14s-gen4), it’s a BIOS issue. There seems to be an update to 1.13 available (mine is running 1.11).
Not sure if that already fixes the problem though.

Answered By: Berty343
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.