Color Calibration Broke After Upgrade From 18 to 22: Enabling / Disabling / Changing Color Profile Does Nothing

I had set up a color profile on my old Ubuntu installation, which was version 18, and it worked great. I didn’t do custom calibration, I just used the provided profile for my ThinkPad T580, and the color it provided was quite good, and it was a big improvement over having the color profiles disabled. I noticed a big improvement, with color management turned off, the display was very washed out, and with it turned on, colors were vibrant and matched other color-managed systems pretty well.

When I upgraded to Ubuntu 22 (which I did by upgrading to 20 and then 22, so I’m not sure which upgrade broke it), this has broken.

However when I open "Color" in settings, it still shows the same profile selected: ThinkPad T580. But it seems to have no effect. Colors are washed out just as they were with my original install before I had enabled color management. Furthermore, when I turn on or off color management, it doesn’t seem to do anything. I even tried changing the profile to a bunch of different colors and the display looks exactly the same. This suggests to me that it doesn’t work.

Is there any way I can fix this or even start troubleshooting it? I am at a complete loss because I see no errors, and I don’t understand what would have changed in the upgrade from 18 to 22, to break this. Yet from my perspective it seems like the current color profile isn’t doing anything. Is there any log anywhere where there might be errors that I am not seeing?

Edit: I found this thread, particularly comments by the user gap:

…Gnome 40 comes to Ubuntu and it does indeed break color management. It looks as if the monitor profile is ignored…

If this is the case, it seems like it would be affecting ALL Ubuntu 22 users, and the problem would have happened in the switch from 20 to 22.

I’m not sure what to do with this though or how to fix it.

Edit: I also tried going into Firefox and manually setting the color profile there, and it doesn’t have any effect. This suggests to me that, contrary to what that thread says, the problem here is not that the applications are not pulling the color profile from the OS.

Asked By: cazort


The reason Color Management is broken with the shift to Ubuntu 22 is that Ubuntu 22 by default uses Wayland, rather than xorg, as the communication protocol between the OS and the display.

And unfortunately, as of the current versions, Wayland does not support color management.

The solution I found was to disable wayland and use xorg, which I did by editing /etc/gdm3/custom.conf, particularly uncommenting the second line below, which is commented out by default:

# Uncomment the line below to force the login screen to use Xorg

I then restarted and this fixed the problem.

Per the comment by @guiverc, you can also select Xorg at the session login screen by selecting the gear at the lower-right corner, which will achieve the same goal without editing any configuration file. I also tested this method and it also solved the problem.

I am quite annoyed that Wayland was pushed as the default with something as important as color management unsupported. Furthermore, I am annoyed that the Color control panel, and the official Ubuntu documentation, does not mention the fact that color management is unsupported nor does it mention a solution. This is, IMHO, a huge oversight and something that I would like to see fixed ASAP.

At a bare minimum I would want the Color control panel in Settings to give a warning that Color Management is unsupported because Wayland is being used, and that you will need to switch back to xorg in order to get it working again. This would have saved hours of debugging.

Answered By: cazort