PC just reboots after installing XanMod kernel

The XanMod kernel description seemed good so Ι wanted to test it out. Ι did what it said on XanMod’s kernel page:

  1. Register the PGP key:

    wget -qO - https://dl.xanmod.org/archive.key | sudo gpg --dearmor -o /usr/share/keyrings/xanmod-archive-keyring.gpg
  2. Add the repository:

    echo 'deb [signed-by=/usr/share/keyrings/xanmod-archive-keyring.gpg] http://deb.xanmod.org releases main' | sudo tee /etc/apt/sources.list.d/xanmod-release.list
  3. Then update and install:

    sudo apt update && sudo apt install linux-xanmod-x64v3
  4. Reboot.

After that I tried booting the XanMod kernel several times with different options and it just rebooted my PC every single time. However, it did not even try to boot up the kernel.

I’m using a Lenovo IdeaPad 3 14IGL05 laptop.

From /proc/cpuinfo:

vendor_id    : GenuineIntel 
cpu family   : 6 
model        : 122 
model name   : Intel(R) Pentium(R) Silver N5030 CPU @ 1.10GHz

Let’s dig further into your hardware.

You have an Intel Pentium Silver N5030 CPU. Googling this gives the following spec sheet.

Here, you can see the CPU family is "Products formerly Gemini Lake Refresh".

Moving on to XanMod.org, we can see in the table that x86-64-v2 is required for the "Intel Goldmont Plus (Gemini Lake)" architecture.

enter image description here

This means you tried to install v3 of the kernel, where you instead should have installed v2. And it did state "Check platform compatibility in x86-64 psABI level reference below.".

So remove variant 3:

sudo apt remove linux-xanmod-x64v3

And install variant 2 instead:

sudo apt install linux-xanmod-x64v2

See if that works. And yes, the instruction on their webpage can be misleading. Write to them if you would have them correct the page.

Answered By: Artur Meinild
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.