No internet connection after upgrading to 5.15.0-83 on Ubuntu 22.04.3

A few days ago I ran an automatic upgrade on my Ubuntu 22.04.3. Today I restarted my PC and it now it cannot connect to the internet.

I tried both Wi-Fi (in 2 different cards) and a LAN cable, but the effect is the same. When trying e.g. ping I get Destination Host Unreachable.

I have 3 versions of kernel available right now:

  1. 5.15.0-83 – internet doesn’t work
  2. 5.15.0-78 – internet doesn’t work
  3. 5.3.0-62 – I cannot boot into this version due to Unable to mount root fs on unknown-block(0,0) error.

I tried to fix the error from (3) by sudo update-initramfs -u -k version (answer found at, I get Can’t find modules.builtin.modinfo error.

Is there anything I can do to make it work? Any help will be much appreciated.

More details

As suggested in the comments:

  1. I ran sudo apt autoclean (and sudo apt autoremove). After rebooting, there was no difference.

  2. ip a returns (I hope for no typos, as I rewrite it manually from the other screen):

    3: wlp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
        inet brd scope global dynamic noprefixroute wlp8s0
    4: wlp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
  3. ls -al /etc/resolv.conf returns:

    /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf
  4. sudo dpkg -s linux-modules-extra-$(uname -r) | grep Status returns:

    Status: install ok installed
  5. As an additional test, when my PC was connected to the Wi-Fi, I tried to print something on a network printer. It printed it without any issues, so the system has access to the local network.

  6. Definitely not a problem with my router, as other computers and phones use it with no issues. I tried to share my LTE connection from a phone and couldn’t make it work on my PC either.

Asked By: sowiq


It appeared that I had a Wireguard VPN activated in the background and the VPN server stopped working for some reason. Since Wireguard doesn’t have any reliable connection indicator for Ubuntu, it wasn’t easy to spot it.

Once I disabled VPN, the internet immediately started to work again. So the problem is solved.

Answered By: sowiq