Ubuntu Server, connected to third-party VPN, cannot be accessed by an external client connected via another VPN


  • Ubiquiti UDM Pro w/Network 7.4.162
  • Server: Ubuntu 20.04 connected to AirPVN
    • eno2
    • eno1 (enabled temporarily to test if adding a 2nd network connection would help—it doesn’t)
    • Air VPN setup by importing OpenVPN config file into GUI Settings > Network interface.
$ ip route
default via dev tun0 proto static metric 50
default via dev eno2 proto dhcp metric 100
default via dev eno1 proto dhcp metric 101 dev eno2 proto kernel scope link src metric 100 dev eno1 proto kernel scope link src metric 101 dev eno2 proto static scope link metric 100 dev tun0 proto kernel scope link src metric 50 dev eno2 scope link metric 1000 dev docker0 proto kernel scope link src dev br-e8acfbc92281 proto kernel scope link src linkdown via dev eno2 proto static metric 100
  • Remote WireGuard Client connected to Ubiquiti UDM Pro


  • The Ubiquiti UDM Pro is my home router.
  • The Ubuntu Server is at my home, connected to the router.
  • The Remote WireGuard Client is my laptop connected through the internet.


When outside my home, connected via my WireGuard VPN, I can access every computer, except the Ubuntu server—if the server is connected to AirVPN. If I drop the AirVPN connection, I can connect to the Ubuntu server just fine.

When the server is connected to AirVPN, Other local computers on the network cacn access the server fine. But Remote VPN Connections (laptop) cannot. Pinging from my laptop leads to timeout. Turning off the AirVPN, pings immediately respond.

  • I’ve tried adding a 2nd Ethernet connection (, but that didn’t help
  • I’ve tried Adding explicit firewall rules from to and and Did not help.

It feels like Ubuntu is responsible for the blocking, not my router.


Is there a way I can allow my Laptop’s WireGuard VPN to connect via my Ubiquiti Router and to my Ubuntu Server, while it is connected to AirVPN? Or is this an intentional mechanic I cannot circumvent?

Thank you.

Asked By: James


There is no answer. It just doesn’t work.

Answered By: James