zenbook ux5304va has no sound from internal speakers on ubuntu 22.04

the lots of zenbooks has similar issue with no sound from internal speakers on all linux distros not just ubuntu due to lack of ACPI entries in the BIOS (we can only hope that Asus updates the BIOS with correct ACPI, but they aren’t supporting Linux, only Windows, and for some reason on Windows sound is working).

My laptop is zenbook_s13_ux5304va, I’ve tried patch from similar laptop: https://gist.github.com/lamperez/862763881c0e1c812392b5574727f6ff but had no success.

I’ve also tried expermental 6.5-rc2 kernel from ubuntu, didn’t worked.

Has anyone been able to run the sound on zenbook_s13_ux5304va maybe? please share the guide on how to do that.

Thanks a lot.

Asked By: Badger UA

||

Install alsamixer, and just play around with it until sound works. Select different devices, channels, I have oone in which I had to mute engineering mode. With alsamixer, you’ll get it working. But you could try gnome control center first. It’s really simple.

Answered By: Brian

I’ve fixed it with custom GRUB SSDT Patch which provides the missing ACPI, however patch doesn’t work with modifications to linux kernel (I’ve also posted info of what needs to be added to kernel to make patch worked)

Fix posted in github: https://github.com/badgers-ua/asus_zenbook_ux5304va_sound

Answered By: Badger UA

I have GREAT news!

I upgraded my kernel in Ubuntu to the latest bleeding edge, 6.7.4, released yesterday on 5 February 2024, and to my amazement, the internal speakers of my Asus Zenbook S13 OLED started magically working!

Here’s how I did it:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update -y
sudo apt install -y mainline
sudo mainline

It should grab and compile the latest kernel. It took about 30 minutes on my Zenbook.

Then reboot. You should have both the native Ubuntu kernel and your new mainline kernel in the grub menu.


Here’s the actual kernel commit for adding support for the Asus Zenbook speakers (added on 12 Nov 2023)… https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=713f040cd22285fcc506f40a0d259566e6758c3c

Answered By: Theodore R. Smith
Categories: Answers Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.