WiFi and bluetooth stopped working after system crash

I have a desktop PC with a motherboard containing WiFi and bluetooth and Ubuntu 22.04. Both were working flawlessly. However, my system crashed and after a reboot (by pressing the restart button on the PC case), both wifi and bluetooth stopped working. The first time it could recognize the bluetooth device but it was not working. Now it does not even recognize the device and says that the system does not have bluetooth nor wifi. I already updated and upgraded, tried to find the drivers for the MB but they are only for windows. Do you think it might have fried the MB controller of those wireless adapters? Is there a way to test if they are still functional? The PC is brand new, it happened on the first day of usage. It’s Ubuntu 22.04 on a AM4 MB.

Edit:

At startup it reports many USB errors -110.

sudo systemctl status bluetooth

Reports:

○ bluetooth.service - Bluetooth service
 Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
 Active: inactive (dead)
   Docs: man:bluetoothd(8)

juil. 22 09:32:02 arthur-MS-7C95 systemd[1]: Condition check resulted in Bluetooth service being skipped.

And if I try to start or enable it reports the same error.

For WiFi, when I run

lspci -knn | grep Net -A3

I get

29:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:0616]
    Subsystem: MEDIATEK Corp. Device [14c3:0616]
    Kernel modules: mt7921e
2a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

Running

sudo dmesg | grep mt7921e

I obtain:

[   69.367523] mt7921e 0000:29:00.0: enabling device (0000 -> 0002)
[   69.367710] mt7921e 0000:29:00.0: ASIC revision: 79220010
[   69.448675]  ? mt7921_dma_enable+0x110/0x110 [mt7921e]
[   69.448682]  mt7921_dma_init+0x194/0x200 [mt7921e]
[   69.448687]  mt7921_register_device+0x29d/0x530 [mt7921e]
[   69.448692]  mt7921_pci_probe.part.0+0x208/0x250 [mt7921e]
[   69.448697]  mt7921_pci_probe+0x43/0x60 [mt7921e]
[   69.448726]  mt7921_pci_driver_init+0x23/0x1000 [mt7921e]
[   69.454398] mt7921e 0000:29:00.0: Firmware init done
[   72.608040] mt7921e 0000:29:00.0: Message 2000008a (seq 2) timeout
[   72.608114] mt7921e: probe of 0000:29:00.0 failed with error -110

I already rebooted into older kernel (5.15.0-25-generic), reinstalled the kernel, but nothing works.

Asked By: Hamesame

||

https://stackoverflow.com/questions/13653692/device-descriptor-read-64-error-110

Just needed to shut down, unplug from the wall for 3-5 minutes and it worked

Answered By: Hamesame