Laptop running too hot, 23.04, almost fresh install

I have a recurring problem with my Dell XPS 9700 and Ubuntu 23.04: the CPU temperature rises to about 60°C causing the fans to get annoyingly loud.
There is no apparent load on the CPU that could be causing this – at least as far as I can see.
Below is the output of sensors to show the problem.

This problem occurred with a previous install, which is why I did a fresh install of Ubuntu 23.04. Luckily for me, this solved the problem for about two weeks. And now I’m back at square one.

What I tried in the previous install is to use tools like i8kmon to "fine-tune" the fan speeds, but this only resulted in a oscillating system (temperature-wise and noise-wise).
I know that this laptop is capable of quite low temperatures under idle conditions. So there must be something going on…

What can I do to diagnose this issue? Is there any information I should provide?

ucsi_source_psy_USBC000:002-isa-0000
Adapter: ISA adapter
in0:          18.00 V  (min = +26.35 V, max = +20.00 V)
curr1:         6.50 A  (max =  +6.50 A)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +40.0°C  

ucsi_source_psy_USBC000:004-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +1.50 A)

dell_smm-isa-0000
Adapter: ISA adapter
fan1:        2633 RPM  (min =    0 RPM, max = 3300 RPM)
fan2:        2626 RPM  (min =    0 RPM, max = 3300 RPM)
temp1:        +64.0°C  
temp2:        +58.0°C  
temp3:        +54.0°C  
temp4:        +63.0°C  
temp5:        +61.0°C  
temp6:        +40.0°C  
temp7:        +60.0°C  
temp8:        +36.0°C  

nvme-pci-0200
Adapter: PCI adapter
Composite:    +36.9°C  (low  =  -5.2°C, high = +82.8°C)
                       (crit = +87.8°C)

ucsi_source_psy_USBC000:003-isa-0000
Adapter: ISA adapter
in0:           0.00 V  (min =  +0.00 V, max =  +0.00 V)
curr1:         3.00 A  (max =  +0.00 A)

ucsi_source_psy_USBC000:001-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +0.00 A)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +64.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +61.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +62.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +62.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +62.0°C  (high = +100.0°C, crit = +100.0°C)
Core 6:        +62.0°C  (high = +100.0°C, crit = +100.0°C)
Core 7:        +63.0°C  (high = +100.0°C, crit = +100.0°C)

pch_cometlake-virtual-0
Adapter: Virtual device
temp1:        +74.0°C  

BAT0-acpi-0
Adapter: ACPI interface
in0:          12.46 V  
curr1:       1000.00 uA 

Just as a follow up, since this might help others who are (like me) not that experienced with Ubuntu/Linux.

I was able to "solve" the problem by reverting to a previous kernel version. For my special case, I knew that everything worked before, so what I did was:

  1. search through the apt install log: pager /var/log/apt/history.log

I found output like this:

Start-Date: 2023-07-13  09:25:01
Commandline: /usr/bin/unattended-upgrade
Install: linux-modules-extra-6.2.0-25-generic:amd64 (6.2.0-25.25, automatic), linux-headers-6.2.0-25:amd64 (6.2.0-25.25, automatic), linux-modules-6.2.0-25-generic:amd64 (6.2.0-25.25, automatic), linux-image-6.2.0-25-generic:amd64 (6.2.0-25.25, au
tomatic), linux-headers-6.2.0-25-generic:amd64 (6.2.0-25.25, automatic)
Upgrade: linux-image-generic-hwe-22.04:amd64 (6.2.0.24.24, 6.2.0.25.25), linux-headers-generic-hwe-22.04:amd64 (6.2.0.24.24, 6.2.0.25.25), linux-generic-hwe-22.04:amd64 (6.2.0.24.24, 6.2.0.25.25), linux-libc-dev:amd64 (6.2.0-24.24, 6.2.0-25.25)
End-Date: 2023-07-13  09:25:27

Which – from my understanding – means that a new kernel version was installed (6.2.0-25.25).

  1. Reboot, and choose previous kernel version during startup. You might need to un-hide the Grub menu.

  2. Make the older kernel the default, by adding

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved 

to /etc/defaults/grub

Any input as to how to debug the underlying issue would be very appreciated. But until then, I’ll just stay at this kernel version and check new ones, to see if the problem is resolved.

Answered By: MelancholyMechanic