Google Chrome Not Displaying Websites Correctly

This issue has made google chrome completely unusable. However, FireFox works just fine. Here is a screenshot of what I am talking about.

Screenshot of Ubuntu stack exchange with corrupted page from Google Chrome

Interestingly, when I was taking the screen shot the bug was even effecting the display of the screenshot box. So, the issue effects the screen outside of just Chrome.

I think the problem could be with the graphics driver for my computer. Another issue I have is the computer won’t go into Suspend when I close the lid and if it is in my backpack it will get warm. I have dug a lot into that issue and it seems like the graphics driver could be the culprit as well.

So, if anyone has insight on how to fix this issue it would be so greatly appreciated. I am completely lost on how to tackle it.

Specs:

  • Ubuntu 22.04.2 LTS
  • Computer Model: Dell Inspiron 7415 2-in-1
  • Processor: AMD Ryzen 5 5500u with radeon graphics x 12
  • Graphics: RENOIR (renoir, LLVM 15.0.7, DRM 3.47, 5.19.0-46-generic)

When doing sudo lshw -c video:

  • description: VGA compatible controller
  • product: Lucienne
  • vendor: AMD/ATI
  • width: 64 bits
  • clock: 33MHz
  • capabilities: pm pciexpress msi msix vga_controller bus_master cap_list fb
  • configuration: depth=32 driver=amdgpu latency=0 mode=1920×1080 resolution=1920,1080 visual=truecolor xres=1920 yres=1080
Asked By: jfwinston32

||

As Jos mentioned if you try to disable the hardware acceleration you should fix the issue, i’ve the same problem with Brave Browser in these days from the last update. I think it’s a bug, hope they will fix it.

Answered By: Simone

Try to open browser in terminal with –disable-gpu flag. This bug is affecting chromium based browsers in Ubuntu.

Answered By: Pravin Kori