Google Chrome isn't properly working

Since I did some updates from Software Updater, Chrome isn’t working. I can open it but all the web pages that I go in to, doesn’t load completely, though the little black wheel is not indicating that is still working. I’ve already tried to update Chrome, reinstall, delete and install it again but is still the same.
Thanks in advance for your help. There’s an image of Youtube’s main page and that’s how Chrome is showing the web pages.

Asked By: MexTaco

||

This seems like a configuration version mismatch issue … Although newer versions should deal properly with old configuration files, but sometimes things that are not expected happen e.g. corruption, invalid lock/status files, user installed extensions, outdated/invalid website specific caches/settings … etc.

At this point and before proceeding, in Google Chrome, you might want to login to your Google account, "turn on sync" and wait until all your personal settings get saved in your google account … This will make it easier to restore them after your browser is fixed.

To see if this is the case, close Google Chrome first … Then backup its configuration directory(should be ~/.config/google-chrome) by renaming it like so:

mv ~/.config/google-chrome ~/.config/old-google-chrome

Now, open Google Chrome and visit a website to see if it works normally and if that is the case, then you know what the culprit is.

Now, your Google Chrome is almost like a clean install … To restore your previous settings, history, bookmarks … etc.:

  • The preferred way is to login to your Google account and "turn on sync" if you have that enabled previously previously and that should restore all your saved settings … Please see the comment by @xtrchessreal(Thank you @xtrchessreal for confirming that)

  • Or, alternatively, you can close Google Chrome again and copy the old configuration directory’s contents over to the new configuration directory with cp‘s option -n, --no-clobber(do not overwrite an existing file) like so:

    cp -nr ~/.config/old-google-chrome/* ~/.config/google-chrome/
    

    Oftentimes, this will keep the newly created version specific configuration files made correctly when you last launched Google Chrome and restore your old configuration.

    In rare times, you might need to selectively copy over the contents of the old configuration directory until you isolate the cause.

Answered By: Raffa

For me seemed the issue is to do with Hardware acceleration (Ubuntu 22.04, Version 114.0.5735.198 (Official Build) (64-bit))

chrome://settings/system uncheck Hardware Acceleration and relaunch.

Answered By: Amos Folarin
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.