Unable to open VLC media Player

I’m getting this error, when I tried to open VLC Media Player via terminal:

Driver does not support the 0x46a8 PCI ID.
libGL error: failed to create dri screen
libGL error: failed to load driver: iris
VLC media player 3.0.18 Vetinari (revision 3.0.18-0-ge9eceaed4d)
[000055c08a393a00] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Qt: Session management error: Could not open network socket
Fontconfig warning: FcPattern object weight does not accept value [0 205)
[1]    74265 segmentation fault (core dumped)  vlc

I’m using freshly installed Ubuntu 23.04 with device configuration:

Processor: Intel 1235U
Graphics: Iris Xe Graphics

I think there is something messed up with the driver but couldn’t figure out the exact problem.

Things I tried:

  1. Updating the driver via software update.
  2. Added following PPA
ppa:kisak/kisak-mesa

None of this works for me.

Asked By: Dhananjay Porwal

||

As I was figuring out all the possibilities of driver issues. I found; this is happed due to outdated version of libgl1-mesa-glx which can easily be fixed by

sudo apt install libgl1-mesa-glx
Answered By: Dhananjay Porwal

I had the same problem a few days ago. VLC media player was unable to open on my laptop. I use the Ubuntu 23.04 version. I searched on the Internet and none of them worked. Then I found out that clearing the caches fixed the problem. Simply run the code on the terminal and you will able to open vlc media player. Here we go:

sudo rm /var/cache/fontconfig/*
rm ~/.cache/fontconfig/*
fc-cache -r

Special thanks to this video: Tutorial Video

Greetings.

Answered By: Shahrear Al Sakib