Wifi not working on Kubuntu 21.10 Kernel 5.13.0 Samsung Galaxy Book Odyssey

I recently bought a Samsung Galaxy Book Odyssey with the hopes of dual-booting Kubuntu and Windows. It has an Intel WiFi 6 AX201 wireless card.

I cannot, for the life of me, get Kubuntu to use the wireless card. It works fine in Windows.

Fast Boot is disabled in Windows, so it is not affecting the card.

I have tried the steps listed in Wifi not working Ubuntu impish 21.10 Kernel 5.13.0 Samsung Galaxy Book Flex2 twice, with no luck so far.

I have also tried installing newer kernel versions to see if the card worked with them, and tried installing the driver provided by Intel at https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html

The output of sudo dmesg | grep iwlw is:

[    4.626793] iwlwifi-stack-public:master:9340:55438a77
[    4.798985] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    4.801507] iwlwifi: No config found for PCI dev 43f0/6074, rev=0x354, rfid=0x10a100
[    4.803363] iwlwifi: probe of 0000:00:14.3 failed with error -22

I can see the wireless card listed without a driver when I do inxi -Fxxxrz:

           DM: SDDM Distro: Ubuntu 21.10 (Impish Indri) 
Machine:   Type: Laptop System: SAMSUNG product: 760XDA v: P04CFE serial: <filter> Chassis: type: 10 serial: N/A 
           Mobo: SAMSUNG model: NP762XDA-XA1US v: SAMSUNG_SW_REVISION_12345+0.0.0000 serial: <filter> 
           UEFI: American Megatrends LLC. v: P04CFE.025.210901.HQ date: 09/01/2021 
Battery:   ID-1: BAT1 charge: 65.7 Wh (85.0%) condition: 77.3/80.0 Wh (96.7%) volts: 12.6 min: 11.6 
           model: SAMSUNG Electronics SR Real Battery type: Li-ion serial: <filter> status: Unknown cycles: 11 
CPU:       Info: 6-Core model: 11th Gen Intel Core i7-11600H bits: 64 type: MT MCP arch: Tiger Lake rev: 1 
           cache: L1: 480 KiB L2: 18 MiB L3: 18 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 70041 
           Speed: 1696 MHz min/max: 800/4600 MHz volts: 0.8 V ext-clock: 100 MHz Core speeds (MHz): 1: 1696 
           2: 1117 3: 2870 4: 2420 5: 3613 6: 2162 7: 1863 8: 1513 9: 2874 10: 3561 11: 3754 12: 1829 
Graphics:  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Samsung Co driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300 
           Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Samsung Co driver: N/A bus-ID: 01:00.0 
           chip-ID: 10de:25a0 class-ID: 0302 
           Device-3: SunplusIT 720p HD Camera type: USB driver: uvcvideo bus-ID: 3-11:5 chip-ID: 2b7e:b500 
           class-ID: 0e02 serial: <filter> 
           Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.2 direct render: Yes 
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: Samsung Co driver: sof-audio-pci-intel-tgl 
           bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.0-22-generic running: yes 
           Sound Server-2: PulseAudio v: 15.0 running: yes 
           Sound Server-3: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Intel Tiger Lake PCH CNVi WiFi driver: N/A port: 5000 bus-ID: 00:14.3 chip-ID: 8086:43f0 
           class-ID: 0280 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co driver: r8169 
           v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
           IF-ID-1: usb0 state: unknown speed: -1 duplex: half mac: <filter> 
Bluetooth: Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-14:6 chip-ID: 8087:0026 class-ID: e001 
           Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 3.0 lmp-v: 5.2 sub-v: 27a4 
           hci-v: 5.2 rev: 27a4 
           Device-2: Samsung GT-I9070 (network tethering USB debugging enabled) type: USB driver: rndis_host 
           v: kernel bus-ID: 3-8:7 chip-ID: 04e8:6864 class-ID: 0a00 serial: <filter> 
Drives:    Local Storage: total: 1.38 TiB used: 13.67 GiB (1.0%) 
           ID-1: /dev/nvme0n1 vendor: SanDisk model: Ultra 3D NVMe size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 
           type: SSD serial: <filter> rev: 211210WD temp: 38.9 C scheme: GPT 
           ID-2: /dev/nvme1n1 model: SSSTC CL1-8D512 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD 
           serial: <filter> rev: E992004 temp: 27.9 C scheme: GPT 
Partition: ID-1: / size: 915.32 GiB used: 13.66 GiB (1.5%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 511 MiB used: 5.2 MiB (1.0%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     Packages: apt: 2065 
           Active apt repos in: /etc/apt/sources.list 
           1: deb http://us.archive.ubuntu.com/ubuntu/ impish main restricted
           2: deb http://us.archive.ubuntu.com/ubuntu/ impish-updates main restricted
           3: deb http://us.archive.ubuntu.com/ubuntu/ impish universe
           4: deb http://us.archive.ubuntu.com/ubuntu/ impish-updates universe
           5: deb http://us.archive.ubuntu.com/ubuntu/ impish multiverse
           6: deb http://us.archive.ubuntu.com/ubuntu/ impish-updates multiverse
           7: deb http://us.archive.ubuntu.com/ubuntu/ impish-backports main restricted universe multiverse
           8: deb http://security.ubuntu.com/ubuntu/ impish-security main restricted
           9: deb http://security.ubuntu.com/ubuntu/ impish-security universe
           10: deb http://security.ubuntu.com/ubuntu/ impish-security multiverse
Info:      Processes: 255 Uptime: 18m wakeups: 3499 Memory: 7.51 GiB used: 2.03 GiB (27.0%) Init: systemd v: 248 
           runlevel: 5 Compilers: gcc: 11.2.0 alt: 11 Shell: Bash (sudo) v: 5.1.8 running-in: konsole 
           inxi: 3.3.06

It also shows up under sudo lshw -class network:

       description: Network controller
       product: Tiger Lake PCH CNVi WiFi
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 11
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: iomemory:610-60f memory:6103144000-6103147fff
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 15
       serial: 8c:b0:e9:1e:89:de
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.13.0-22-generic firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:16 ioport:3000(size=256) memory:51204000-51204fff memory:51200000-51203fff
       description: Ethernet interface
       physical id: 2
       bus info: usb@3:8
       logical name: usb0
       serial: 6a:35:3c:99:ab:e4
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.13.0-22-generic duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair

Any help would be greatly appreciated and thanks in advance.

Asked By: KD0AZT


Use this answer to patch your kernel module
Intel AX201 Wi-Fi 6 is not working on Ubuntu 21.04

In my case on Kubuntu 22.10 I made next steps:

  1. install backport-iwlwifi-dkms
    sudo apt install backport-iwlwifi-dkms

  2. edit /usr/src/backport-iwlwifi-9904/dkms.conf


  1. Add 43f0/6074 into

IWL_DEV_INFO(0x43f0, 0x6074, iwl_ax201_cfg_qu_hr, NULL),

  1. rebuild iwlwifi
  • sudo dkms remove backport-iwlwifi/9904
  • sudo dkms add backport-iwlwifi/9904
  • sudo dkms build backport-iwlwifi/9904
  • sudo dkms install backport-iwlwifi/9904
  1. reboot and see dmesg
$ sudo dmesg | grep iw
[    6.289399] iwlwifi_compat: loading out-of-tree module taints kernel.
[    6.325815] Loading modules backported from iwlwifi
[    6.325827] iwlwifi-stack-public:master:9904:0e80336f
[    6.594572] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    6.606285] iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
[    6.606305] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version:
[    6.606684] iwlwifi 0000:00:14.3: loaded firmware version 73.35c0a2c6.0 QuZ-a0-hr-b0-73.ucode op_mode iwlmvm
[    6.698789] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x351
[    6.826456] iwlwifi 0000:00:14.3: Detected RF HR B5, rfid=0x10a100
[    6.892314] iwlwifi 0000:00:14.3: base HW address: 48:51:c5:a4:85:f8
[    6.906865] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
Answered By: Vladimir X

Finally able to get wifi working on this card. It’s in the current iwlwifi backport:

Sudo apt-get install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
make defconfig-iwlwifi-public
make -j4
sudo make install

Then reboot and wifi should work.

(instructions modified from here as it has been added directly to the backport, no file changes needed anymore.)

Answered By: KD0AZT