Internal Monitor Not Detected Ubuntu 21.10 Acer Nitro 5

I have an Acer Nitro 5 and I recently installed Ubuntu 21.10. I noticed a bit of lag when I tried semi-intensive stuff, then realized I was running the Intel Integrated Graphics. I tried multiple steps to try to get Nvidia as the default, and I think I did, but the problem now is my 2nd monitor won’t turn on.
When I go into the installation media on the USB, it works as expected. But when I return to my normal, installed OS, it won’t work correctly.

I have tried multiple methods, but I am unable to find the links to them all atm, so feel free to pitch your solutions and I’ll let you know if I tried it.

Things I have tried: Restarting, unplugging/plugging, reinstalling drivers, switching drivers, and attempted to disable Secure Boot (which I couldn’t figure out).

Update: I was forced to do the password stuff and BOK password, now my external monitor works but the internal one doesn’t.

Asked By: Pokegamer129


The answer to this was a lot, but here it is.

The original problem, which was the external monitor not working, was solved by typing the MOK key to enable Secure Boot. (Though, disabling it works too supposedly).

The next problem, the internal monitor not working, was solved by this command line. (As seen with the lines, it works with Nvidia specifically)

cd /etc/X11
sudo rm xorg.conf
sudo cp xorg.conf.nvidia-xconfig-original xorg.conf
Answered By: Pokegamer129

What worked for me was this. Hope it helps someone else.

Before logging in you can choose between "Ubuntu" and "Ubuntu on Xorg". Apparently "Ubuntu" works better with screen sharing in my case.

Image of Ubuntu’s log in

Answered By: Kevin
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.