Gnome panel and menu bar can't be clicked..!

I am using Ubuntu Lucid Lynx. I installed it using the feature ‘Install within Windows’. I got a simple though difficult problem.


The touchpad and external mouse movements are working fine.

I am able to :

  • Maximize, minimize, and close an opened window using the buttons on the window.
  • Drag a window by double-clicking and holding it.
  • Rise up a context menu with a right-click on the window border.
  • Scroll through a page with the Mouse wheel.

I am not able to :

  • Left-click or right-click on a panel.
  • Open a menu item from the menu bar using a click.
  • Open a folder by double-clicking it.
  • Rise up a context menu for a right-click inside the window area.
  • Click an item in the side pane.
  • Scroll through a page by dragging the scroll bar.
  • Select OK or cancel in the pop-up windows with a click. [To do so, I have to use tab to go to the option and press enter].

It happened as follows :

I finished installing the packages planets, sugar-emulator, rlplot, gsynaptics, then opened the package planets, and added a planet in the opened window.

**The planets window said to press Ctrl + Shift to release the mouse from its window to a normal ubuntu environment. I doubt my keystroke was wrong. I am not sure what I pressed. Something wrong went from there. **

I thought a restart would clear the problem, but it didn’t. I removed all the installed packages and their dependencies and restarted my laptop. Still, the problem exists.

I am using my laptop with all the keyboard shortcuts I know. And I have to press tab many times to select something and it is really bad.

Solution?

  1. Should I install any drivers for my touchpad?
  2. Is there any option to restore my system to an earlier point in time as is possible in windows?
  3. Should I change any settings?
  4. Can I recover using any bootup installation?
Asked By: Vinay

||

Your gnome settings are corrupted some how. Instead of spending time debugging them all, your quickest solution is to create a new user and move over your document files. The other option is to try and reset the options for gnome:

From a terminal which you can get to by going Applications > Accessories > Terminal, copy and paste the following:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

This will remove all of your gnome settings and set them to the default settings. These files are normally hidden files and you don’t normally see them in your home folder from nautilus (nautilus is the file manager that is shown when you go to Places > Home).

Log off and back on to apply the changes.

At least for the panel, you should try restarting the panel via “gnome-panel –replace” command to see if this temporary solves your problem (until next restart). In Ubuntu 10.04 my Desktop didn’t have any problems, but with my Laptop, 80% of times I had to restart the panel at boot time ( there was a bug in gnome ).

If @Martin Owens solution doesn’t work you could use KDE for a while ( it will be easier to have a working station to help you find a solution, that what I did in 10.10, where in gnome the mouse could not click anything but in KDE worked ). KDE is instaled from software center as kubuntu package, or in CLI with this command :sudo apt-get install kubuntu-desktop

Answered By: Radu Maris

The solution to the problem was very simple

Click in the menu
"System"
"Preferences"
"Windows"
Then under "Movement Key"
select the radio button for "super (or "Windows Logo")

I don’t know if this is the way it is supposed to be set or if it is backwards now (I never looked at this setting before) but my mouse now works correctly on
Ubuntu 10.04

http://ubuntuforums.org/showthread.php?t=1512841

Answered By: Catabras

Try to kill and re-run your panel app process.

Can’t run terminal?

If you are unable to start the Terminal (e.g. using a shortcut Alt+F2), but can run file manager,

you can find the Terminal in: /usr/bin/gnome-terminal (or generally in /usr/bin/*)

  1. Search for a panel process (e.g. gnome-system-monitor > tab “Processes”, search for something *-panel), for me it was xfce4-panel, for you it is probably gnome-panel

  2. Run terminal

  3. Kill all of it: sudo killall gnome-panel

  4. Start it again sudo gnome-panel &

If you have Xubuntu, your panel app process is probably xfce4-panel, then, of course:

sudo killall xfce4-panel

sudo xfce4-panel &

Answered By: jave.web

Some of the behavior mentioned here, happened to me as well in while using Xubuntu 18.04, I solved it by going into the XFCE Panel Switch and reapplying my current configuration.

Hope it helps.

Answered By: vipulgupta2048

On Linux Mint 21, I had the same behaviour, at least:

  • no clicks on the Linux start menu,
  • no clicks on the taskbar, no clicks on the open programs, but Alt+Tab worked,
  • in one of the Firefox windows, I could not click on the tabs, in the other, I could click and work as always,
  • I did not check it further, but it was perhaps in line with more or even all of the bullet points of the question.

Fix: suspend and wake up the OS.